View Issue Details

IDProjectCategoryView StatusLast Update
0011394LazarusLCLpublic2011-10-10 12:37
ReporterPhil Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPowerPCOSOS X 
Product Version0.9.25 (SVN) 
Target Version1.0.0 
Summary0011394: TBitBtn font changes size on second ShowModal
DescriptionSee attached project.

When Form1's button is clicked the second time, Form2's TBitBtn label shrinks, whereas its TButton label stays the same.

Also odd behavior with GTK, where both buttons' font is displayed smaller the second time Form2 is displayed.

Thanks.

-Phil
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetCarbon
Attached Files

Activities

2008-06-01 03:06

 

project1.zip (4,017 bytes)

Dmitry Boyarintsev

2011-10-03 03:41

developer   ~0052403

the bug seems to be fixed in the meantime. could you please retest and confirm?

Issue History

Date Modified Username Field Change
2008-06-01 03:06 Phil New Issue
2008-06-01 03:06 Phil File Added: project1.zip
2008-06-01 03:06 Phil Widgetset => Carbon
2008-06-01 09:42 Vincent Snijders LazTarget => 1.0
2008-06-01 09:42 Vincent Snijders Assigned To => Tom Gregorovic
2008-06-01 09:42 Vincent Snijders Status new => acknowledged
2008-06-01 09:42 Vincent Snijders Target Version => 1.0.0
2008-06-02 16:07 Vincent Snijders Status acknowledged => assigned
2008-09-14 12:06 Tom Gregorovic Status assigned => confirmed
2011-04-03 13:31 Zeljan Rikalo Status confirmed => assigned
2011-04-03 13:31 Zeljan Rikalo Assigned To Tom Gregorovic => Dmitry Boyarintsev
2011-10-03 03:41 Dmitry Boyarintsev Note Added: 0052403
2011-10-03 03:41 Dmitry Boyarintsev Status assigned => feedback
2011-10-10 12:36 Vincent Snijders Status feedback => resolved
2011-10-10 12:36 Vincent Snijders Resolution open => fixed