View Issue Details

IDProjectCategoryView StatusLast Update
0011456LazarusWidgetsetpublic2018-11-05 15:23
ReporterChrisK Assigned ToFelipe Monteiro de Carvalho  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN) 
Fixed in Version0.9.25 (SVN) 
Summary0011456: Problems with dialog-sizes
DescriptionThere are two errors with dialogs:
1. They appear much bigger than set in the IDE
2. Each time they are shown via .ShowModal, their width is decreased by 5
Tagswince
Fixed in Revision15378, 21262
LazTarget-
WidgetsetWinCE
Attached Files

Relationships

related to 0010656 closedFelipe Monteiro de Carvalho Patches WinCE form's ClientRect is 1 pixel too large on right and bottom sides 
related to 0024124 assignedFelipe Monteiro de Carvalho Lazarus Regression related to fullscreen and message dialogs 
related to 0025966 resolvedLacaK Lazarus InputBox dialog is to wide on a Windows CE device 

Activities

2008-06-10 14:21

 

DialogWidth_Error.zip (543,818 bytes)

Felipe Monteiro de Carvalho

2008-06-10 15:49

developer   ~0020073

Still with very latest subversion?

ChrisK

2008-06-10 15:52

reporter   ~0020074

I tested with
> Lazarus-0.9.25-fpc-2.2.3-20080610-win32.exe
> Lazarus-0.9.25-fpc-2.2.3-20080610-cross-arm-wince-win32.exe
from the daily builds...

Felipe Monteiro de Carvalho

2008-06-11 01:33

developer   ~0020083

Ok, I found the problem and fixed it.

ChrisK

2008-06-11 14:00

reporter   ~0020091

The width and height is still decreased every time, the dialog is shown.
First time, the dialog has the right size, but when I open (showmodal) it a second time, it becomes smaller.

Felipe Monteiro de Carvalho

2008-06-11 16:01

developer   ~0020093

Last edited: 2008-06-11 16:02

How did you test?

The snapshots are *not* instantaneous. Only 1 is made per day. What revision are you using? I think you can find the revision in the about dialog.

It needs to be > 15378

ChrisK

2008-06-11 20:34

reporter   ~0020095

My SVN-Version is 15383...

I made two screenshots. One after the first showmodal and one after the second.

2008-06-11 20:35

 

1st_showmodal.png (6,950 bytes)   
1st_showmodal.png (6,950 bytes)   

2008-06-11 20:35

 

2nd_showmodal.png (6,145 bytes)   
2nd_showmodal.png (6,145 bytes)   

Felipe Monteiro de Carvalho

2008-06-20 15:49

developer   ~0020218

I looked everywhere, but I can't find the cause of the problem. If you need this anytime soon I suggest that you also start debugging lcl-wince. Maybe you will see something I missed.

ChrisK

2008-06-21 13:18

reporter   ~0020233

I couldn't find the cause too. I avoided the bug by setting the dialog-size in its OnShow-Event.
This solution isn't very nice, but works for me ;)

Chris

Felipe Monteiro de Carvalho

2009-08-17 16:50

developer   ~0029928

It isn't reproducible with wince-win32. I hate it when bugs only appear on the device ...

Felipe Monteiro de Carvalho

2009-08-17 17:56

developer   ~0029930

I found the problem, it was in function TWinCEWidgetSet.GetWindowSize

It seams that after placing the dialog the LCL checks its size, and changes the LCL control size if it differs. That routine calculates the size of the window and the win32 code uses SM_CXSIZEFRAME for borders, which returns 3 in my wince emulator, but the real border is only 1 pixel wide, like SM_CXBORDER.

Issue History

Date Modified Username Field Change
2008-06-10 14:21 ChrisK New Issue
2008-06-10 14:21 ChrisK File Added: DialogWidth_Error.zip
2008-06-10 14:21 ChrisK Widgetset => WinCE
2008-06-10 15:48 Felipe Monteiro de Carvalho Tag Attached: wince
2008-06-10 15:49 Felipe Monteiro de Carvalho LazTarget => -
2008-06-10 15:49 Felipe Monteiro de Carvalho Note Added: 0020073
2008-06-10 15:49 Felipe Monteiro de Carvalho Status new => feedback
2008-06-10 15:52 ChrisK Note Added: 0020074
2008-06-11 01:33 Felipe Monteiro de Carvalho Fixed in Revision => 15378
2008-06-11 01:33 Felipe Monteiro de Carvalho Status feedback => resolved
2008-06-11 01:33 Felipe Monteiro de Carvalho Fixed in Version => 0.9.25 (SVN)
2008-06-11 01:33 Felipe Monteiro de Carvalho Resolution open => fixed
2008-06-11 01:33 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2008-06-11 01:33 Felipe Monteiro de Carvalho Note Added: 0020083
2008-06-11 14:00 ChrisK Status resolved => feedback
2008-06-11 14:00 ChrisK Resolution fixed => reopened
2008-06-11 14:00 ChrisK Note Added: 0020091
2008-06-11 16:01 Felipe Monteiro de Carvalho Note Added: 0020093
2008-06-11 16:02 Felipe Monteiro de Carvalho Note Edited: 0020093
2008-06-11 20:34 ChrisK Note Added: 0020095
2008-06-11 20:35 ChrisK File Added: 1st_showmodal.png
2008-06-11 20:35 ChrisK File Added: 2nd_showmodal.png
2008-06-14 06:18 Felipe Monteiro de Carvalho Status feedback => confirmed
2008-06-20 15:49 Felipe Monteiro de Carvalho Note Added: 0020218
2008-06-21 13:18 ChrisK Note Added: 0020233
2009-03-12 20:59 Felipe Monteiro de Carvalho Relationship added related to 0010656
2009-08-17 16:50 Felipe Monteiro de Carvalho Note Added: 0029928
2009-08-17 17:56 Felipe Monteiro de Carvalho Fixed in Revision 15378 => 15378, 21262
2009-08-17 17:56 Felipe Monteiro de Carvalho Status confirmed => resolved
2009-08-17 17:56 Felipe Monteiro de Carvalho Resolution reopened => fixed
2009-08-17 17:56 Felipe Monteiro de Carvalho Note Added: 0029930
2011-12-01 11:22 Marc Weustink Status resolved => closed
2014-09-15 14:55 Felipe Monteiro de Carvalho Relationship added related to 0024124
2018-11-05 15:23 LacaK Relationship added related to 0025966