View Issue Details

IDProjectCategoryView StatusLast Update
0011590Lazarus CCRglscenepublic2010-01-29 18:54
ReporterReenen Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status feedbackResolutionopen 
PlatformWindowsOSVISTA 
Summary0011590: Really funny displays on Vista laptop
DescriptionOn the link below you can see an odd strip of white that turns to black in about the middle on the very top of the GLSceneViewer component.
http://i6.photobucket.com/albums/y212/reenen/WhiteTop.png



Steps To ReproduceOnly tested with this application
Additional Information
A very similar behaviour can be observed in on the "cardname" which reads Ancestral Vi...

This text is generated with
cvas.TextOut(...);

where cvas is

cvas:=TCanvas.Create;
cvas.Handle:=Scn.RenderDC ;

where Scn is the GLSceneViewer.
TagsNo tags attached.
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0013235 closedVincent Snijders Lazarus TOpenGLControl does not work with XP Manifests enabled 
has duplicate 0011589 closedVincent Snijders Lazarus CCR Really funny displays on Vista laptop 

Activities

2008-06-30 20:58

 

screenshots.zip (612,355 bytes)

Burkhard Carstens

2008-07-01 06:13

developer   ~0020474

Last edited: 2008-07-01 06:17

Could you please verify, if this is related to bug 0011321 ? (see description of that bug)

Might also be related to bug 0011578 ..

I suspect this being a LCL bug rather than a glscene bug ..

theo

2008-07-01 09:06

reporter   ~0020480

Could it be caused by graphics card / driver?
I've read similar issues here: (not Laz. related)
http://dev.newswhat.com/amsg/borland.public.delphi.non-technical/48654cca$1@newsgroups.borland.com.html

Reenen

2008-07-12 11:08

reporter   ~0020662

My suspicion is also a Graphics driver, but latest drivers (for Vista) didn't fix it.

I am not at all knowledgeable enough on the subject to know if any of those bugs would be related. (They also don't have screenshots... and somehow I think that it describes it much better).

Reenen

2008-08-02 16:56

reporter   ~0021040

If you change your Vista Appearance back to Windows "Classic" theme (or whatever they call it on Vista) it works correctly!

Won't call it a fix, more a workaround, but it is definitely a GLScene issue.

Burkhard Carstens

2010-01-29 18:54

developer   ~0034036

Related bug 0013235 seems fixed. Please retest with a recent lazarus version (svn or nightly snapshot).

Issue History

Date Modified Username Field Change
2008-06-30 20:58 Reenen New Issue
2008-06-30 20:58 Reenen File Added: screenshots.zip
2008-06-30 20:58 Reenen Widgetset => Win32
2008-06-30 21:03 Vincent Snijders Relationship added has duplicate 0011589
2008-07-01 06:13 Burkhard Carstens LazTarget => -
2008-07-01 06:13 Burkhard Carstens Note Added: 0020474
2008-07-01 06:13 Burkhard Carstens Status new => feedback
2008-07-01 06:17 Burkhard Carstens Note Edited: 0020474
2008-07-01 09:06 theo Note Added: 0020480
2008-07-12 11:08 Reenen Note Added: 0020662
2008-08-02 16:56 Reenen Note Added: 0021040
2008-08-25 12:35 Vincent Snijders Status feedback => acknowledged
2009-09-03 17:48 Vincent Snijders Project Packages => Lazarus CCR
2010-01-29 18:52 Burkhard Carstens Relationship added related to 0013235
2010-01-29 18:54 Burkhard Carstens Note Added: 0034036
2010-01-29 18:54 Burkhard Carstens Status acknowledged => feedback