View Issue Details

IDProjectCategoryView StatusLast Update
0011626LazarusIDEpublic2013-09-03 12:07
ReporterGraeme Geldenhuys Assigned ToPaul Ishenin  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Platformx86OSUbuntu Linux 
Product Version0.9.25 (SVN) 
Fixed in Version0.9.27 (SVN) 
Summary0011626: Line Change Indicators
DescriptionThe Gutter shows information about the status of the lines in the editor. Lines changed since the last save are marked with a yellow bar. Lines changed since the file was first opened and before the last save are marked with green.

See attached animated gif show the feature in action (image courtesy of Delphi 2007 website).
TagsNo tags attached.
Fixed in Revision17624,17626,17635,17720
LazTarget1.4
Widgetset
Attached Files

Activities

2008-07-07 14:52

 

line_change_indicators.gif (68,043 bytes)   
line_change_indicators.gif (68,043 bytes)   

Mattias Gaertner

2008-07-07 15:40

manager   ~0020592

Eclipse calls this feature 'Quick Diff'.
It shows Changes, Additions and Deletions compared to the disk or CVS/SVN.
Colors and compare target can be configured.

Mattias Gaertner

2008-07-07 15:43

manager   ~0020593

And BTW: The first time I saw this in eclipse, I thought it was a graphic bug.
Maybe some eye candy should be used, so that it looks like a feature and not like a bug.

Christian

2008-12-08 07:54

reporter   ~0023704

As i see it is implemented in meantime ?!

Paul Ishenin

2008-12-08 08:01

manager   ~0023705

Yes, I've implemented them. Info is not extremely accurate and can be improved but in generally it works. Please close if ok.

Graeme Geldenhuys

2008-12-08 09:30

reporter   ~0023709

Works fine. Thanks!

Issue History

Date Modified Username Field Change
2008-07-07 14:52 Graeme Geldenhuys New Issue
2008-07-07 14:52 Graeme Geldenhuys File Added: line_change_indicators.gif
2008-07-07 14:52 Graeme Geldenhuys Widgetset => GTK, GTK 2, Win32, WinCE, Carbon, QT, fpGUI
2008-07-07 14:55 Vincent Snijders LazTarget => post 1.2
2008-07-07 14:55 Vincent Snijders Status new => acknowledged
2008-07-07 15:40 Mattias Gaertner Note Added: 0020592
2008-07-07 15:43 Mattias Gaertner Note Added: 0020593
2008-08-06 22:06 Mattias Gaertner Widgetset GTK, GTK 2, Win32, WinCE, Carbon, QT, fpGUI =>
2008-12-07 22:27 Vincent Snijders Status acknowledged => assigned
2008-12-07 22:27 Vincent Snijders Assigned To => Paul Ishenin
2008-12-08 07:54 Christian Note Added: 0023704
2008-12-08 08:01 Paul Ishenin Fixed in Revision => 17624,17626,17635,17720
2008-12-08 08:01 Paul Ishenin Status assigned => resolved
2008-12-08 08:01 Paul Ishenin Fixed in Version => 0.9.27 (SVN)
2008-12-08 08:01 Paul Ishenin Resolution open => fixed
2008-12-08 08:01 Paul Ishenin Note Added: 0023705
2008-12-08 09:30 Graeme Geldenhuys Status resolved => closed
2008-12-08 09:30 Graeme Geldenhuys Note Added: 0023709
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4