View Issue Details

IDProjectCategoryView StatusLast Update
0011766LazarusLCLpublic2013-09-03 12:07
Reporterrse Assigned ToVincent Snijders  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformWin32OSWindows XP SP2 
Product Version0.9.25 (SVN) 
Fixed in Version0.9.27 (SVN) 
Summary0011766: OnShowHint not shown in Object Inspector
DescriptionThe OnShowHint event is not shown in Object Inspector.
TagsNo tags attached.
Fixed in Revision16793
LazTarget1.4
WidgetsetWin32/Win64
Attached Files

Activities

Mattias Gaertner

2008-07-29 10:17

manager   ~0020991

What control?

rse

2008-07-30 17:25

reporter   ~0021004

Only a few controls (TListBox is the only one I found on a quick´n´dirty search on "Standard" page) show it. One could say it´s only interesting for controls which show multiple items (such as ListBox and Memo), but where to set things like HintInfo^.HideTimeOut? In my opinion it should be shown for every descendant of TControl.

Mattias Gaertner

2008-07-30 17:44

manager   ~0021005

The OI shows only published properties and properties are published only in the leave classes (e.g. TPanel, not TCustomPanel, not TControl).
You must give concrete classes for which you have tested, that OnShowHint works on windows and linux.
Otherwise it is not a bug report, but a design guide line and we never know, when the bug is fixed.

rse

2008-07-30 22:51

reporter   ~0021007

Last edited: 2008-07-30 22:53

You mean, that this is not published yet in most classes because it´s untestet with most controls?
Otherwise I just could post a list of controls where it´s not published. The Bug would then be fixed when every control in the list would publish the property "OnShowHint"?
Btw. I don´t have a clue of linux, I only work with Windows.

Vincent Snijders

2008-08-25 12:40

manager   ~0021688

Then at least test on windows. We try to prevent publishing poperties that don't work. Before changing a property from Public to Published, it should be tested that it actually works. No use in having a non-functional published property, it only generates frustration and bug reports.

rse

2008-08-31 17:17

reporter   ~0021837

Oh, Ok. If that´s the official way (which IS reasonable), then there´s no reason for this report and you may close it. I´m sorry, but I don´t feel experienced enough to fully test this.

Vincent Snijders

2008-08-31 19:06

manager   ~0021839

Testing is simple. Just create an application, in which you would want to set the OnShowHint in the object inspector. But now just set it in the Form On Create event. Then test that the application works as expected.

For now, I leave this bug report open as feature request.

2008-09-01 10:39

 

OnShowHint.zip (2,542 bytes)

rse

2008-09-01 10:44

reporter   ~0021871

I uploaded my test program, which works fine (the Hint shows) on my WinXP SP2 with Lazarus 0.9.25 20080316. Since it´s not possible to install 2 different Lazarus versions just by running the installation routine any more and I had problems with recent beta I will upgrade to the soon coming 0.9.26 when it´s ready. But if you haven´t changed the OnShowHint since 03/16/2008 this test will do.

Vincent Snijders

2008-09-29 14:09

manager   ~0022492

I published TForm.OnShowHint, because that one is tested in the test application.

Issue History

Date Modified Username Field Change
2008-07-29 01:51 rse New Issue
2008-07-29 01:51 rse Widgetset => Win32
2008-07-29 10:17 Mattias Gaertner LazTarget => -
2008-07-29 10:17 Mattias Gaertner Note Added: 0020991
2008-07-29 10:17 Mattias Gaertner Status new => feedback
2008-07-30 17:25 rse Note Added: 0021004
2008-07-30 17:44 Mattias Gaertner Note Added: 0021005
2008-07-30 22:51 rse Note Added: 0021007
2008-07-30 22:53 rse Note Edited: 0021007
2008-08-25 12:40 Vincent Snijders Note Added: 0021688
2008-08-31 17:17 rse Note Added: 0021837
2008-08-31 19:06 Vincent Snijders LazTarget - => post 1.2
2008-08-31 19:06 Vincent Snijders Note Added: 0021839
2008-08-31 19:06 Vincent Snijders Severity minor => feature
2008-09-01 10:39 rse File Added: OnShowHint.zip
2008-09-01 10:44 rse Note Added: 0021871
2008-09-29 14:09 Vincent Snijders Fixed in Revision => 16793
2008-09-29 14:09 Vincent Snijders Status feedback => resolved
2008-09-29 14:09 Vincent Snijders Fixed in Version => 0.9.27 (SVN)
2008-09-29 14:09 Vincent Snijders Resolution open => fixed
2008-09-29 14:09 Vincent Snijders Assigned To => Vincent Snijders
2008-09-29 14:09 Vincent Snijders Note Added: 0022492
2008-10-09 15:34 rse Status resolved => closed
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4