View Issue Details

IDProjectCategoryView StatusLast Update
0011830LazarusWidgetsetpublic2009-06-13 12:09
ReporterRoss Hemingway Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN) 
Target Version1.0.0Fixed in Version0.9.28 
Summary0011830: Carbon - TListbox 'in place editor' problems
DescriptionSVN15810 (20080718)

TListBox, TCheckListBox, etc. The 'in place text editor' ability is active, and interferes with line items in a TListBox.
Additional InformationTo produce:

New application, add a TListBox, add several Items (TStrings), Run.

Single click a listbox item (focus it), at the text portion of the line, hover and wait, the control will go into editor mode. But it's:
a/ white text on white background,
b/ doesn't actually edit correctly,
c/ user focus is lost due to this error,
c/ not normal behavior of a TListBox or its related controls.
TagsNo tags attached.
Fixed in Revisionr18728
LazTarget1.0
WidgetsetCarbon
Attached Files

Activities

Dmitry Boyarintsev

2009-02-17 13:07

developer   ~0025493

Fixed. In-place editor should no longer appear at the TListBox or TCheckListBox.
Please test and close if ok.

Issue History

Date Modified Username Field Change
2008-08-10 06:06 Ross Hemingway New Issue
2008-08-10 06:06 Ross Hemingway Widgetset => Carbon
2008-08-10 08:15 Vincent Snijders LazTarget => 1.0
2008-08-10 08:15 Vincent Snijders Status new => acknowledged
2008-08-10 08:15 Vincent Snijders Target Version => 1.0.0
2009-02-17 13:07 Dmitry Boyarintsev Status acknowledged => resolved
2009-02-17 13:07 Dmitry Boyarintsev Resolution open => fixed
2009-02-17 13:07 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2009-02-17 13:07 Dmitry Boyarintsev Note Added: 0025493
2009-02-17 13:55 Dmitry Boyarintsev Status resolved => assigned
2009-02-17 13:55 Dmitry Boyarintsev Resolution fixed => reopened
2009-02-17 13:56 Dmitry Boyarintsev Fixed in Revision => r18728
2009-02-17 13:56 Dmitry Boyarintsev Status assigned => resolved
2009-02-17 13:56 Dmitry Boyarintsev Fixed in Version => 0.9.28
2009-02-17 13:56 Dmitry Boyarintsev Resolution reopened => fixed
2009-06-13 12:09 Marc Weustink Status resolved => closed