View Issue Details

IDProjectCategoryView StatusLast Update
0001186LazarusIDEpublic2010-04-23 11:21
ReporterFelipe Monteiro de CarvalhoAssigned ToMarc Weustink 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.9 (SVN)Product Build 
Target Version1.0.0Fixed in Version 
Summary0001186: "Key combos" do not work on the source code editor on gtk
DescriptionI am unable to write ã, á, à, é, í, ó, ü and other international characters in the lazarus source code editor on Linux. With either gtk or gtk2. On Windows the behavior is normal.

Typing ~ + A will result on "~A" not a "Ã".

The reason behind this feature request is to The alow non-english people to write comments on their own language.

The compiler should have no trouble handling any utf-8 character, so this is a gtk IDE problem.

"Key combos" work pretty well on TEdit.
Additional InformationI use ABNT2, the most standard brazilian keyboard.

Here are de specifications:

[felipe@Lapa ~]$ setxkbmap -v
Trying to build keymap using the following components:
keycodes: xfree86(abnt2)+aliases(qwerty)
types: complete
compat: complete
symbols: pc/pc(pc104)+pc/br+compose(rwin)
geometry: pc(abnt2)

My editor font is "bitstream vera sans mone" and this font accepts international characters on kwrite.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK, GTK 2
Attached Files

Relationships

has duplicate 0007017 closedBart Broersma Accents and Ñ (capital n with tilde) doesn't work in editor 
has duplicate 0007742 closedBart Broersma SynEdit cannot write accent chars even with font.CharSet = UNICODE 
has duplicate 0008855 acknowledged Editor does not support fully international keyboard layout 
has duplicate 0009755 closedVincent Snijders Entering single quote character from keyboard becomes A´ in Editor. 

Activities

Bart Broersma

2009-12-02 11:58

developer   ~0032658

I think this has been fixed in the meantime, with LCL now fully supporting UTF8?

Jesus Reyes

2009-12-02 21:42

developer   ~0032675

Last edited: 2009-12-02 21:47

This is not fixed, at least in not in every OpenSuse system I tried (10.0, 11.0, 11.1) KDE, Gtk2 widgetset, locale: es_MX.UTF-8, generic 104 keys keyboard, spain-es layout. for example I cannot type the dereference pointer ^ character. Everywhere but Lazarus editor I type this character with the key combo: [SHIFT+^] followed by [SHIFT+^] (ie two times) or by typing [SHIFT+^] followed by [SPACE]

In order to use this ^ character I have to copy and paste it from other place, this is not nice, the same with accented chars. "ñ" char works fine.

EDIT: on native TEdit key combo works, but it prints twice the ^ character.

Felipe Monteiro de Carvalho

2009-12-03 13:55

developer   ~0032691

It is working for me in Ubuntu 7.04 with Gtk 2 and Lazarus 0.9.29

Bart Broersma

2010-02-22 12:44

developer   ~0034666

No feedback from reporter.
Seems to be fixed in the meantime.
Please test and close if fixed, ore re-opern if issue remains.

Issue History

Date Modified Username Field Change
2005-09-19 18:19 Felipe Monteiro de Carvalho New Issue
2005-09-19 18:19 Felipe Monteiro de Carvalho Widgetset => GTK, GTK 2
2005-09-20 03:33 Vincent Snijders Target => 1.0
2005-09-20 03:33 Vincent Snijders Assigned To => Marc Weustink
2005-09-20 03:33 Vincent Snijders Status new => acknowledged
2006-06-06 17:18 Felipe Monteiro de Carvalho Relationship added has duplicate 0007017
2006-11-04 00:31 Felipe Monteiro de Carvalho Relationship added has duplicate 0007742
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2008-06-09 04:49 Felipe Monteiro de Carvalho Relationship added has duplicate 0008855
2009-12-02 11:58 Bart Broersma Note Added: 0032658
2009-12-02 11:58 Bart Broersma Status acknowledged => feedback
2009-12-02 12:08 Bart Broersma Relationship added has duplicate 0009755
2009-12-02 21:42 Jesus Reyes Note Added: 0032675
2009-12-02 21:47 Jesus Reyes Note Edited: 0032675
2009-12-03 13:55 Felipe Monteiro de Carvalho Note Added: 0032691
2010-02-22 12:44 Bart Broersma Status feedback => resolved
2010-02-22 12:44 Bart Broersma Resolution open => fixed
2010-02-22 12:44 Bart Broersma Note Added: 0034666
2010-04-23 11:21 Bart Broersma Status resolved => closed