View Issue Details

IDProjectCategoryView StatusLast Update
0011906LazarusLCLpublic2009-06-13 12:10
ReporterAntonyAssigned ToPaul Ishenin 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN)Product Build 
Target Version0.9.28Fixed in Version0.9.27 (SVN) 
Summary0011906: TMemo borderstyle in gtk
DescriptionHas non-published but public borderStyle property, but does not appear to obey it (e.g. BorderStyle:=bsNone)

(gtk version of http://mantis.freepascal.org/view.php?id=11785)
TagsNo tags attached.
Fixed in Revision19036,19038
LazTarget0.9.28
WidgetsetGTK
Attached Files

Activities

Vincent Snijders

2008-08-18 12:43

manager   ~0021442

It is probably not published, because it is not implemented.

Antony

2008-08-18 21:07

reporter   ~0021460

It works fine in win32 and carbon. Selectable read-only text areas are very useful!

I would pay a small bounty to fix this.

Paul Ishenin

2009-03-20 05:28

manager   ~0026253

This is fixed for gtk2. For gtk1 it is not possible to implement since both GtkEntry and GtkScrolledWindow does not allow to change frame visibility.

Please test and close if ok.

Issue History

Date Modified Username Field Change
2008-08-17 17:52 Antony New Issue
2008-08-17 17:52 Antony Widgetset => GTK
2008-08-18 12:43 Vincent Snijders Note Added: 0021442
2008-08-18 12:43 Vincent Snijders LazTarget => post 1.2
2008-08-18 12:43 Vincent Snijders Status new => acknowledged
2008-08-18 12:43 Vincent Snijders Severity minor => feature
2008-08-18 21:07 Antony Note Added: 0021460
2009-03-20 05:28 Paul Ishenin Fixed in Revision => 19036,19038
2009-03-20 05:28 Paul Ishenin LazTarget post 1.2 => 0.9.28
2009-03-20 05:28 Paul Ishenin Status acknowledged => resolved
2009-03-20 05:28 Paul Ishenin Fixed in Version => 0.9.27 (SVN)
2009-03-20 05:28 Paul Ishenin Resolution open => fixed
2009-03-20 05:28 Paul Ishenin Assigned To => Paul Ishenin
2009-03-20 05:28 Paul Ishenin Note Added: 0026253
2009-03-20 05:28 Paul Ishenin Target Version => 0.9.28
2009-06-13 12:10 Marc Weustink Status resolved => closed