View Issue Details

IDProjectCategoryView StatusLast Update
0012065LazarusIDEpublic2009-06-13 10:08
ReporterGraeme Geldenhuys Assigned ToVincent Snijders  
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionno change required 
Platformx86OSUbuntu Linux 
Product Version0.9.25 (SVN) 
Target Version1.0.0 
Summary0012065: Popup dialogs cause flicker effect in IDE
DescriptionUsing Lazarus v0.9.25 r16425M i386-linux-gtk

When pressing the keyboard shortcut to bring up the "Goto Line number"
dialog, all other opened windows (Project Inspector, Package windows
etc) flicker like crazy. It's as if all the other dialogs get a
"bring to front" and then a "sent to back" action. They briefly moved over the editor window, then quickly get sent back behind the editor window. Very distracting!

This doesn't just happen when I open the "Goto line number" dialog. It
happens with any "popup" dialog, like (Ctrl+F) for Search dialog;
(Ctrl+Shift+D) for Conditional Defines dialog, etc... Any "popup"
dialog, causes all other open windows (part of Lazarus IDE) to flicker (as previously described).

It doesn't seem to be related to my choice of window managers either.
I tested it under both Gnome and FVWM. Same behaviour. This also
started happening in the last few svn updates (week or two ago).
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK
Attached Files

Activities

Graeme Geldenhuys

2008-09-15 08:02

reporter   ~0022238

Weird one... I don't normally reboot my computer. My workstation keeps running for 1-2 weeks at a time before reboots. [Linux is awesome].

Anyway, after a reboot and a new svn update of Lazarus, the flicker is gone. It's been a week now and still can't reproduce the issue. So I guess this report can be closed.

Vincent Snijders

2008-09-15 08:30

manager   ~0022240

Thanks for the feedback.

Issue History

Date Modified Username Field Change
2008-09-05 08:57 Graeme Geldenhuys New Issue
2008-09-05 08:57 Graeme Geldenhuys Widgetset => GTK
2008-09-13 09:20 Vincent Snijders LazTarget => 1.0
2008-09-13 09:20 Vincent Snijders Status new => acknowledged
2008-09-13 09:20 Vincent Snijders Target Version => 1.0.0
2008-09-15 08:02 Graeme Geldenhuys Note Added: 0022238
2008-09-15 08:30 Vincent Snijders Status acknowledged => resolved
2008-09-15 08:30 Vincent Snijders Resolution open => no change required
2008-09-15 08:30 Vincent Snijders Assigned To => Vincent Snijders
2008-09-15 08:30 Vincent Snijders Note Added: 0022240
2009-06-13 10:08 Marc Weustink Status resolved => closed