View Issue Details

IDProjectCategoryView StatusLast Update
0012105LazarusWidgetsetpublic2014-09-21 16:09
ReporterDimitrios Chr. Ioannidis Assigned ToFelipe Monteiro de Carvalho  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionunable to reproduce 
Product Version0.9.25 (SVN) 
Summary0012105: simple project Exception 'External SIGSEGV'
Descriptionfpc and fpc-cross is 2.2.2.
Lazarus v0.9.25 r16496 i386-win32-win32/win64

I made a new project and run it inside the IDE.

On startup i got 'Project project1 raised exception 'External SIGSEGV'. Pressing F9 continues execution.
Additional InformationDebug output :

"
...


(gdb)

~"2741000:compime.dll\n"

*stopped,reason="signal-received",signal-name="SIGSEGV",signal-meaning="Segmentation fault",thread-id="1",frame={addr="0x0002bb84",func="GETHINTINFOATMOUSE",args=[{name="result",value="{MOUSEPOS = {X = -1232824631, Y = -1433495565}, CONTROL = 0x9720, CONTROLHASHINT = true (20)}"}],file="application.inc",line="70"}

(gdb)

<-stack-list-frames 0 0>
^done,stack=[frame={level="0",addr="0x0002bb84",func="GETHINTINFOATMOUSE",file="application.inc",line="70"}]

(gdb)

...
"
TagsNo tags attached.
Fixed in Revision
LazTarget1.4
WidgetsetWinCE
Attached Files

Relationships

related to 0026757 assignedStephano [Patch] AV when destroying form with menu 

Activities

Dimitrios Chr. Ioannidis

2008-09-09 10:43

reporter   ~0022085

PocketPC - Windows Mobile 2003 Second Edition 4.21.1088 (Build 14235)

project compile options

"
-Sgi -MObjFPC -O1 -TWinCE -Parm -g -WG -vewnhi -l -Fu..\..\source\ -Fu..\..\..\..\..\..\Compiler\ObjectPascal\LazarusIDE\lcl\units\arm-wince\ -Fu..\..\..\..\..\..\Compiler\ObjectPascal\LazarusIDE\lcl\units\arm-wince\wince\ -Fu..\..\..\..\..\..\Compiler\ObjectPascal\LazarusIDE\packager\units\arm-wince\ -Fu. -FUppu\ -o..\..\bin\DPIfaistos-arm-wince.exe -dLCL -dLCLwince
"

Dimitrios Chr. Ioannidis

2008-09-09 11:17

reporter   ~0022086

Update: This is only happening if the project has a TMainMenu. Without a TMainMenu the exception is not shown.

Felipe Monteiro de Carvalho

2009-08-17 16:49

developer   ~0029934

Please upload a complete compilable test project, without it I cannot reproduce and will close the bug. Projects with TMainMenu work fine for me

Issue History

Date Modified Username Field Change
2008-09-09 10:40 Dimitrios Chr. Ioannidis New Issue
2008-09-09 10:40 Dimitrios Chr. Ioannidis Widgetset => WinCE
2008-09-09 10:43 Dimitrios Chr. Ioannidis Note Added: 0022085
2008-09-09 11:17 Dimitrios Chr. Ioannidis Note Added: 0022086
2008-09-11 01:49 Paul Ishenin LazTarget => post 1.2
2008-09-11 01:49 Paul Ishenin Status new => acknowledged
2008-09-11 16:14 Felipe Monteiro de Carvalho Status acknowledged => assigned
2008-09-11 16:14 Felipe Monteiro de Carvalho Assigned To => Felipe Monteiro de Carvalho
2009-08-17 16:49 Felipe Monteiro de Carvalho Note Added: 0029934
2009-08-17 16:49 Felipe Monteiro de Carvalho Status assigned => feedback
2009-08-25 14:39 Felipe Monteiro de Carvalho Status feedback => resolved
2009-08-25 14:39 Felipe Monteiro de Carvalho Resolution open => unable to reproduce
2009-10-21 11:52 Dimitrios Chr. Ioannidis Status resolved => closed
2013-09-03 10:07 Martin Friebe LazTarget post 1.2 => 1.4
2014-09-21 16:09 Juha Manninen Relationship added related to 0026757