View Issue Details

IDProjectCategoryView StatusLast Update
0012146LazarusIDEpublic2010-02-07 19:45
ReporterChristian Assigned ToVincent Snijders  
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Platformintel macOSMacOS-X 
Product Version0.9.25 (SVN) 
Target Version0.9.28Fixed in Version0.9.27 (SVN) 
Summary0012146: Application starter (.app) dont work on i386 Mac
DescriptionInstalled dmg from today snapshot (16584)
Klicked on the Application Icon appears in /Applications
Splash screen appears
nothing happens .... seems lazarus has closed without exception

going to /Applications/Lazarus.app/Contents/MacOS
./lazarus

...lazarus starts
TagsNo tags attached.
Fixed in Revision20348
LazTarget0.9.28
WidgetsetCarbon
Attached Files

Relationships

related to 0012069 closedVincent Snijders CARBON: IDE left old instance alive after rebuild and restart itself (rebuild IDE) 

Activities

Karl-Michael Schindler

2008-09-14 22:47

reporter   ~0022231

Last edited: 2008-09-14 22:49

Confirmed the bug. The only thing I found was in /Library/Logs/Console/($my UID)/consol.log:

2008-09-14 22:33:10 +0200
Adding "-psn_0_28704769" as a parameter
TCarbonWindow.SetScrollInfo TODO
TCarbonWindow.SetScrollInfo TODO
TCarbonWindow.SetScrollInfo TODO
TCarbonWindow.SetScrollInfo TODO
TLazarusManager.Run starting /Developer/lazarus/lazarus.app/Contents/MacOS/lazarus ...
TCarbonPrinter.ValidatePageFormat Error: PMSessionValidatePageFormat failed with result -30876
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/Users/($my username)/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
NOTE: editor options config file not found - using defaults
NOTE: miscellaneous options file not found - using defaults
NOTE: codetools config file not found - using defaults

NOTE: Compiler Filename not set! (see Environment Options)

NOTE: Lazarus Source Directory not set! (see Environment Options)

NOTE: FPC Source Directory not set! (see Environment Options)
RegisterProcess failed (error = -2805)

Christian

2008-09-15 08:53

reporter   ~0022233

The notes are also an big -
Seems the default paths show to /usr/local/share/lazarus
But lazarus is installed now in /Developer

Vincent Snijders

2008-09-15 09:33

manager   ~0022235

IIRC, Karl-Michael reported that Lazarus starts correctly on Mac OS X 10.5.

Christian, where do you see that "the default paths show to /usr/local/share/lazarus". I don't understand what you mean in note 22223.

Tom Gregorovic

2008-09-15 10:51

developer   ~0022242

Last line "RegisterProcess failed (error = -2805)" is the important.

Vincent Snijders

2008-09-15 14:24

manager   ~0022253

Googling gave this information:
cfragDupRegistrationErr = -2805, /* The registration name was already in use.*/

But I don't know what to do with it.

Vincent Snijders

2008-09-18 07:39

manager   ~0022321

Can you try the following:
Rename the link in /Applications/Lazarus.app/Contents/MacOS/lazarus to
startlazarus and change in
Contents/Info.plist the CFBundleExecutable key to 'startlazarus'.

Christian

2008-09-18 07:59

reporter   ~0022322

dont works

Felipe Monteiro de Carvalho

2008-09-19 03:45

developer   ~0022331

I think that there is no need for startlazarus in Mac OS X, because you can write to the executable file while it is being run, so we could ignore it, and use lazarus directly.

Vincent Snijders

2008-09-19 06:29

manager   ~0022332

You can not (or should not) be able to write to lazarus, if it is installed by the sysadmin and you are a mere user without admin access.

You need to write to it to install components. So a new lazarus is created in ~/.lazarus/bin. That one doesn't get started if you don't use startlazarus, even on Mac OS X.

Tom Gregorovic

2008-09-19 18:38

developer   ~0022338

I can reproduce this error always when running startlazarus.app, although executing startlazarus goes right.

Mattias Gaertner

2008-09-23 15:04

manager   ~0022381

Someone reported, that an alias instead of a symlink works for him.

Vincent Snijders

2008-09-24 15:45

manager   ~0022420

No solution was found. Postponed to the next release.

As a work around for user on Mac OS X before 10.5, they can start lazarus from a terminal.

Dmitry Boyarintsev

2008-11-11 14:20

developer   ~0023300

Last edited: 2008-11-11 14:22

Lazarus refuses to launch, because name collision happens. /Applicaitons/Lazarus.App/Content/MacOS/lazarus
should be renamed to startlazarus (as it launches startlazarus). PINfo.list must be accordinally updated too.

Yes, launching so, will make TWO lazarus Icons appear at the dock (first one is 'startlazarus' and second one is 'lazarus' itself)

This can be avoided by adding LSUIElements (string value = "1") to /Developers/Lazarus/Lazarus.app/Contents/PInfo.list

(see ref: http://developer.apple.com/documentation/MacOSX/Conceptual/BPRuntimeConfig/Articles/PListKeys.html)

this make lazarus app, dock invisible.

Dmitry Boyarintsev

2008-11-11 14:25

developer   ~0023301

but still, it's better to get rid of startlazarus for Mac OS X.

Mattias Gaertner

2008-11-19 18:55

manager   ~0023446

Thanks for the hint.

startlazarus is needed to install packages and hide the gory details to the user.

Dmitry Boyarintsev

2009-05-30 10:46

developer   ~0028147

Last edited: 2009-05-30 10:49

These two patches are changing installation snapshot, by removing additional /Applications/Lazarus.app bundle, replacing it with alias (symbolic link) to the /Developer/lazarus/lazarus.app bundle.

create_lazarus_dmg.sh.diff:

Index: create_lazarus_dmg.sh
===================================================================
--- create_lazarus_dmg.sh (revision 20299)
+++ create_lazarus_dmg.sh (working copy)
@@ -145,12 +145,9 @@
 ln -s /Developer/lazarus/lazbuild lazbuild
 cp $TEMPLATEDIR/uninstall.sh $ROOTDIR/Developer/lazarus/
 
-# create /Applications/Lazarus.app for startlazarus
+# create /Applications/Lazarus.app alias
 mkdir -p $ROOTDIR/Applications
-cp -R $LAZBUILDDIR/lazarus.app $ROOTDIR/Applications/Lazarus.app
-cd $ROOTDIR/Applications/Lazarus.app/Contents/MacOS/
-rm -f lazarus startlazarus
-ln -s /Developer/lazarus/startlazarus lazarus
+ln -s /Developer/lazarus/lazarus.app $ROOTDIR/Applications/Lazarus.app

2009-05-30 10:48

 

2009-05-30 10:48

 

Vincent Snijders

2009-06-05 15:39

manager   ~0028305

Dmitry, thanks for the research and the patches.

Christian

2009-10-23 01:21

reporter   ~0031599

Dont close my bugs until ive had the chance to test, thanks.

Vincent Snijders

2009-10-23 07:31

manager   ~0031604

Last edited: 2009-10-23 09:04

Issues are administratively closed after a couple of months. What do you think is a reasonable time to confirm a fix? I think one or two months is a reasonable time, certainly for people that use svn.

Issue History

Date Modified Username Field Change
2008-09-14 22:01 Christian New Issue
2008-09-14 22:01 Christian Widgetset => Carbon
2008-09-14 22:20 Vincent Snijders LazTarget => 0.9.26
2008-09-14 22:20 Vincent Snijders Assigned To => Mattias Gaertner
2008-09-14 22:20 Vincent Snijders Status new => assigned
2008-09-14 22:20 Vincent Snijders Target Version => 0.9.26
2008-09-14 22:47 Karl-Michael Schindler Note Added: 0022231
2008-09-14 22:49 Karl-Michael Schindler Note Edited: 0022231
2008-09-15 08:53 Christian Note Added: 0022233
2008-09-15 09:33 Vincent Snijders Note Added: 0022235
2008-09-15 10:51 Tom Gregorovic Note Added: 0022242
2008-09-15 14:24 Vincent Snijders Note Added: 0022253
2008-09-18 07:39 Vincent Snijders Note Added: 0022321
2008-09-18 07:59 Christian Note Added: 0022322
2008-09-19 03:45 Felipe Monteiro de Carvalho Note Added: 0022331
2008-09-19 06:29 Vincent Snijders Note Added: 0022332
2008-09-19 18:38 Tom Gregorovic Note Added: 0022338
2008-09-23 15:04 Mattias Gaertner Note Added: 0022381
2008-09-24 15:45 Vincent Snijders LazTarget 0.9.26 => 0.9.28
2008-09-24 15:45 Vincent Snijders Note Added: 0022420
2008-09-24 15:45 Vincent Snijders Target Version 0.9.26 => 0.9.27 (SVN)
2008-09-26 21:31 Vincent Snijders Target Version 0.9.27 (SVN) => 0.9.28
2008-11-11 14:20 Dmitry Boyarintsev Note Added: 0023300
2008-11-11 14:22 Dmitry Boyarintsev Note Edited: 0023300
2008-11-11 14:25 Dmitry Boyarintsev Note Added: 0023301
2008-11-19 18:55 Mattias Gaertner Note Added: 0023446
2009-04-21 17:06 Dmitry Boyarintsev Assigned To Mattias Gaertner => Dmitry Boyarintsev
2009-05-24 16:25 Dmitry Boyarintsev Relationship added related to 0012069
2009-05-30 10:46 Dmitry Boyarintsev Note Added: 0028147
2009-05-30 10:47 Dmitry Boyarintsev Note Edited: 0028147
2009-05-30 10:48 Dmitry Boyarintsev File Added: create_lazarus_dmg.sh.diff.zip
2009-05-30 10:48 Dmitry Boyarintsev File Added: lazarus_packproj.template.diff.zip
2009-05-30 10:49 Dmitry Boyarintsev Note Edited: 0028147
2009-06-03 22:48 Vincent Snijders Assigned To Dmitry Boyarintsev => Vincent Snijders
2009-06-05 15:39 Vincent Snijders Fixed in Revision => 20348
2009-06-05 15:39 Vincent Snijders Status assigned => resolved
2009-06-05 15:39 Vincent Snijders Fixed in Version => 0.9.27 (SVN)
2009-06-05 15:39 Vincent Snijders Resolution open => fixed
2009-06-05 15:39 Vincent Snijders Note Added: 0028305
2009-10-23 00:39 Marc Weustink Status resolved => closed
2009-10-23 01:21 Christian Status closed => assigned
2009-10-23 01:21 Christian Resolution fixed => reopened
2009-10-23 01:21 Christian Note Added: 0031599
2009-10-23 07:31 Vincent Snijders Note Added: 0031604
2009-10-23 09:04 Vincent Snijders Note Edited: 0031604
2009-10-23 09:05 Vincent Snijders Status assigned => resolved
2009-10-23 09:05 Vincent Snijders Resolution reopened => fixed
2010-02-07 19:45 Christian Status resolved => closed