View Issue Details

IDProjectCategoryView StatusLast Update
0012153LazarusWidgetsetpublic2009-10-23 00:40
ReporterJoao Morais Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN) 
Fixed in Version0.9.27 (SVN) 
Summary0012153: Main menu shortcuts does not work
DescriptionThe main menu shortcuts of the Lazarus IDE does not work. Alt+F doesn't open the file menu as well as the "F" hasn't an underline. The same happens with or without the focus in the main window. Btw the other shortcuts (eg Ctrl+O to open a file) do work.

OS is Ubuntu 7.10, default installation and additional packages in order to compile the IDE (binutils, devel packages and the like).

The widget set is GTK2, last night (14/9) fpc (branch_2_2) and lazarus (trunk) revisions.
TagsNo tags attached.
Fixed in Revision
LazTarget1.2
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0010282 closedMattias Gaertner Main menu not accessible via alt shortcuts (e.g. alt+f for File) 
related to 0009396 closedMartin Friebe Synedit blocks some main menu shortcuts 
has duplicate 0012582 closedVincent Snijders Main form shortcuts do not work on gtk with alt-modifier 

Activities

Christian

2008-09-15 18:51

reporter   ~0022258

when the system uses the same shortcuts they cant work

Vincent Snijders

2008-09-15 19:21

manager   ~0022260

AFAIK, already reported.

Paul Ishenin

2009-06-13 04:43

manager   ~0028512

Menu shortcuts in gtk2 were fixed in 0.9.27 version. Please test and close if it works for you now.

Issue History

Date Modified Username Field Change
2008-09-15 18:42 Joao Morais New Issue
2008-09-15 18:42 Joao Morais Widgetset => GTK 2
2008-09-15 18:51 Christian Note Added: 0022258
2008-09-15 19:21 Vincent Snijders Note Added: 0022260
2008-09-15 23:15 Vincent Snijders LazTarget => 1.2
2008-09-15 23:15 Vincent Snijders Status new => acknowledged
2008-09-15 23:16 Vincent Snijders Category LCL => Widgetset
2008-09-16 14:34 Vincent Snijders Relationship added duplicate of 0010282
2009-03-06 13:45 Martin Friebe Relationship added related to 0012582
2009-03-06 13:45 Martin Friebe Relationship added related to 0009396
2009-04-17 16:54 Martin Friebe Relationship replaced has duplicate 0012582
2009-06-13 04:43 Paul Ishenin Status acknowledged => resolved
2009-06-13 04:43 Paul Ishenin Fixed in Version => 0.9.27 (SVN)
2009-06-13 04:43 Paul Ishenin Resolution open => fixed
2009-06-13 04:43 Paul Ishenin Assigned To => Paul Ishenin
2009-06-13 04:43 Paul Ishenin Note Added: 0028512
2009-10-23 00:40 Marc Weustink Status resolved => closed