View Issue Details

IDProjectCategoryView StatusLast Update
0012176LazarusLCLpublic2013-09-03 12:07
ReporterGerard V Assigned ToBart Broersma  
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.25 (SVN) 
Fixed in Version0.9.27 (SVN) 
Summary0012176: TFloatSpinEdit and TSpinEdit do accept non-numeric characters in the edit box
DescriptionBoth TFloatSpinEdit and TSpinEdit will allow you to type non-numeric characters in the edit box.
I think the direct entry should be restricted to digits '0'..'9', editing keys (left, right, backspace, del...) and the current comma separator character.
TagsNo tags attached.
Fixed in Revision18456
LazTarget1.4
Widgetset
Attached Files

Relationships

duplicate of 0013045 closedBart Broersma TFloatSpinEdit should not accept "invalid keys" as input 

Activities

Bart Broersma

2009-02-23 16:59

developer   ~0025679

Please test and close if OK.

Gerard V

2009-02-24 10:44

reporter   ~0025698

Fixed, thanks

Issue History

Date Modified Username Field Change
2008-09-18 10:39 Gerard V New Issue
2008-09-18 10:40 Vincent Snijders LazTarget => post 1.2
2008-09-18 10:40 Vincent Snijders Status new => acknowledged
2009-02-23 16:57 Bart Broersma Relationship added duplicate of 0013045
2009-02-23 16:59 Bart Broersma Fixed in Revision => 18456
2009-02-23 16:59 Bart Broersma Status acknowledged => resolved
2009-02-23 16:59 Bart Broersma Fixed in Version => 0.9.27 (SVN)
2009-02-23 16:59 Bart Broersma Resolution open => fixed
2009-02-23 16:59 Bart Broersma Assigned To => Bart Broersma
2009-02-23 16:59 Bart Broersma Note Added: 0025679
2009-02-24 10:44 Gerard V Status resolved => closed
2009-02-24 10:44 Gerard V Note Added: 0025698
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4