View Issue Details

IDProjectCategoryView StatusLast Update
0012359FPCCompilerpublic2009-03-20 12:57
ReporterMehmet Erol SanliturkAssigned ToMarco van de Voort 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version2.2.4 
Summary0012359: c:\fpc\2.2.2\examples\gtk1 and gtk2 : ReadMe.TXT Additions
Description
(A)


The following sample ReadMe.TXT file
may be inserted into the following directory :


http://svn.freepascal.org/svn/fpc/trunk/packages/gtk1/examples/


ReadMe.TXT

---------------------------


The following libraries are needed to run the
example programs supplied in this directory :


In Windows :


libintl-1.dll
libgdk-0.dll
libgtk-0.dll
libglib-2.0-0.dll

gtkgl.dll ( required only for gtkgldemo.pp )



In FreeBSD :


In GNU/Linux :


---------------------------



(B)


The following sample ReadMe.TXT file
may be inserted into the following directory :


http://svn.freepascal.org/svn/fpc/trunk/packages/gtk2/examples/


ReadMe.TXT

---------------------------


The following libraries are needed to run the
example programs supplied in this directory :


In Windows :

libgdkglext-win32-1.0.0.dll
libglade-2.0-0.dll


In FreeBSD :


In GNU/Linux :


---------------------------



(C)


For the program

c:\fpc\2.2.2\examples\gtk2\gtk_demo\gtk_demo.exe

I mentioned the zero division exception .


Dear Paul Ishenin notified me about a Windows bug in his message :

http://www.mail-archive.com/fpc-devel@lists.freepascal.org/msg12237.html


as


" This is a known bug on windows.

Use the folowing call in your application initialization section:

Set8087CW($133F); "


Into

c:\fpc\2.2.2\examples\gtk2\gtk_demo\gtk_demo.pas

I added the above statement as

  .
  .
  .

var
 window,
 notebook,
 hbox,
 tree : PGtkWidget;

begin


{$ifdef win32}

 Set8087CW($133F);


{$else}

{$endif}


 current_file := NULL;

  .
  .
  .


The program worked very well .


Addition of the following statement


{$ifdef win32}

 Set8087CW($133F);

{$else}

{$endif}


into


http://svn.freepascal.org/svn/fpc/trunk/packages/gtk2/examples/gtk_demo/gtk_demo.pas


will prevent zero division exception in Windows applications .




Into the directory


http://svn.freepascal.org/svn/fpc/trunk/packages/gtk2/examples/gtk_demo/


the following sample ReadMe.TXT file may be added :


ReadMe.TXT

---------------------------


The following statement in Windows
prevents zero division exception :


{$ifdef win32}

 Set8087CW($133F);

{$else}

{$endif}


---------------------------
TagsNo tags attached.
Fixed in Revision
FPCOldBugId0
FPCTarget
Attached Files

Activities

Marco van de Voort

2008-10-18 16:25

manager   ~0022812

I think it is better to keep this in the wiki (and maybe add wiki page URL to the sources). This because availability of dlls can quickly change.

Marco van de Voort

2008-11-27 22:41

manager   ~0023619

Added to the respective pages of the wiki.

Issue History

Date Modified Username Field Change
2008-10-12 01:32 Mehmet Erol Sanliturk New Issue
2008-10-12 19:25 Marc Weustink Project Mantis => FPC
2008-10-18 16:25 Marco van de Voort Note Added: 0022812
2008-11-27 22:41 Marco van de Voort Status new => resolved
2008-11-27 22:41 Marco van de Voort Resolution open => fixed
2008-11-27 22:41 Marco van de Voort Assigned To => Marco van de Voort
2008-11-27 22:41 Marco van de Voort Note Added: 0023619
2009-03-20 12:57 Jonas Maebe FPCOldBugId => 0
2009-03-20 12:57 Jonas Maebe Status resolved => closed
2009-03-20 12:57 Jonas Maebe Category => Compiler
2009-03-20 12:57 Jonas Maebe Fixed in Version => 2.2.4
2009-03-20 12:57 Jonas Maebe Description Updated