View Issue Details

IDProjectCategoryView StatusLast Update
0012396LazarusWidgetsetpublic2008-11-09 17:27
Reporterdaoo Assigned ToPaul Ishenin  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformlinux amd64OSubuntu 64-bit 
Product Version0.9.27 (SVN) 
Target Version1.0.0Fixed in Version0.9.27 (SVN) 
Summary0012396: Lazarus crashes when trying to copy text in the editor.
DescriptionGTK 2.14.3, Ubuntu 8.10 beta, 64-bit.
When trying to copy text (ctrl-c) in the editor lazarus crashes.
Steps To Reproduce1. Open lazarus
2. In the text editor try to copy some text (ctrl-c).
3. Crash
Additional InformationBack-trace attached.
TagsNo tags attached.
Fixed in Revision17272
LazTarget1.0
WidgetsetGTK 2
Attached Files

Relationships

has duplicate 0012407 closedPaul Ishenin Lazarus crash with GTK+ 2.14.3 
has duplicate 0012557 closedPaul Ishenin Clipboard operations do not work at all 
child of 0008165 closedMattias Gaertner GTK2 - suggested to be default 

Activities

2008-10-14 22:40

 

backtrace (5,556 bytes)   
(gdb) backtrace
#0  0x00007fd17d990fd5 in raise () from /lib/libc.so.6
#1  0x00007fd17d992b43 in abort () from /lib/libc.so.6
#2  0x00007fd17d9d1fa8 in ?? () from /lib/libc.so.6
#3  0x00007fd17d9d7938 in ?? () from /lib/libc.so.6
#4  0x00007fd17d9d9f86 in free () from /lib/libc.so.6
#5  0x00000000008947c5 in CLEARTARGETLISTS (WIDGET=0x24094d0, parentfp=0x7fff87e37b20) at ../gtk/gtkwidgetset.inc:5058
#6  0x000000000089465e in SETCLIPBOARDWIDGET (TARGETWIDGET=0x0, this=0x7fd17fc6c160) at ../gtk/gtkwidgetset.inc:5078
#7  0x0000000000896132 in CLIPBOARDGETOWNERSHIP (CLIPBOARDGETOWNERSHIP=false, CLIPBOARDTYPE=CTCLIPBOARD, ONREQUESTPROC=
      {Proc = {procedure (^pointer, QWord, ^TSTREAM = class )} 0x7fff87e37c08, Self = 0x7fd17fcc5600}, FORMATCOUNT=1, FORMATS=0x7fd176d35660, this=0x7fd17fc6c160) at ../gtk/gtkwinapi.inc:689
#8  0x000000000076e892 in CLIPBOARDGETOWNERSHIP (CLIPBOARDGETOWNERSHIP=true (255), CLIPBOARDTYPE=CTCLIPBOARD, ONREQUESTPROC=
      {Proc = {procedure (^pointer, QWord, ^TSTREAM = class )} 0x7fff87e37c48, Self = 0x7fd17fcc5600}, FORMATCOUNT=1, FORMATS=0x7fd176d35660) at include/lclintf.inc:92
#9  0x000000000084943a in GETOWNERSHIP (GETOWNERSHIP=true (209), this=0x7fd17fcc5600) at include/clipbrd.inc:217
#10 0x000000000084953a in ENDUPDATE (ENDUPDATE=true, this=0x7fd17fcc5600) at include/clipbrd.inc:249
#11 0x0000000000849e93 in SETBUFFER (SETBUFFER=false, FORMATID=125, BUFFER=@0x7fd17fcc5670, SIZE=60, this=0x7fd17fcc5600) at include/clipbrd.inc:412
#12 0x000000000084a16b in SETASTEXT (VALUE=0x7fd17fcc5790 'reate (Sender: TObject );'#10'    procedure Timer1Timer (Sender', this=0x7fd17fcc5600) at include/clipbrd.inc:453
#13 0x0000000000a5a03d in DOCOPYTOCLIPBOARD (STEXT=0x7fd17fcc5790 'reate (Sender: TObject );'#10'    procedure Timer1Timer (Sender', this=0x7fd17816d1b0) at synedit.pp:1334
#14 0x0000000000a5a32f in COPYTOCLIPBOARD (this=0x7fd17816d1b0) at synedit.pp:1425
#15 0x0000000000a6d7aa in EXECUTECOMMAND (COMMAND=201, ACHAR='', DATA=0x0, this=0x7fd17816d1b0) at synedit.pp:8366
#16 0x0000000000a6a9b9 in COMMANDPROCESSOR (COMMAND=201, ACHAR='', DATA=0x0, this=0x7fd17816d1b0) at synedit.pp:7497
#17 0x0000000000a5cf68 in KEYDOWN (KEY=@0x7fff87e38838, SHIFT=4, this=0x7fd17816d1b0) at synedit.pp:2274
#18 0x00000000007b6b03 in KEYDOWNBEFOREINTERFACE (KEY=@0x7fff87e38838, SHIFT=4, this=0x7fd17816d1b0) at include/wincontrol.inc:4981
#19 0x00000000007b6e91 in DOKEYDOWNBEFOREINTERFACE (DOKEYDOWNBEFOREINTERFACE=true, MESSAGE=@0x7fff87e38830, this=0x7fd17816d1b0) at include/wincontrol.inc:5117
#20 0x00000000007b90c5 in CNKEYDOWN (MESSAGE=@0x7fff87e38830, this=0x7fd17816d1b0) at include/wincontrol.inc:6200
#21 0x000000000065f980 in SYSTEM_TOBJECT_$__DISPATCH$formal ()
#22 0x00000000007b90a8 in ?? ()
#23 0x00007fd17816d1b0 in ?? ()
#24 0x00000000012f6300 in _$SYNEDIT$_Ld74 ()
#25 0x00007fd10000001b in ?? ()
#26 0x000000000000bd00 in ?? ()
#27 0x00007fff87e38830 in ?? ()
#28 0x00007fd17816d1b0 in ?? ()
#29 0x00000000005e33e8 in ?? ()
#30 0x000000000296c400 in ?? ()
#31 0x00000000027550a0 in ?? ()
#32 0x00000000025c8d80 in ?? ()
#33 0x00007fff87e38a70 in ?? ()
#34 0x000000000296c400 in ?? ()
#35 0x00007fd17fc284aa in ?? () from /lib64/ld-linux-x86-64.so.2
#36 0x00000000007b6068 in WNDPROC (MESSAGE=@0x7fff87e38830, this=0x7fd17816d1b0) at include/wincontrol.inc:4749
#37 0x0000000000a69466 in WNDPROC (MSG=@0x7fff87e38830, this=0x7fd17816d1b0) at synedit.pp:7008
#38 0x00000000008b3565 in DELIVERMESSAGE (DELIVERMESSAGE=6757422, TARGET=0x7fd17816d1b0, AMESSAGE=@0x7fff87e38830) at ../gtk/gtkproc.inc:3547
#39 0x00000000008b0176 in HANDLEGTKKEYUPDOWN (HANDLEGTKKEYUPDOWN=false, AWIDGET=0x25c8d80, AEVENT=0x28b70a0, ADATA=0x7fd178b545d0, ABEFOREEVENT=true, AHANDLEDOWN=true) at ../gtk/gtkproc.inc:2264
#40 0x000000000086254a in GTK2KEYDOWN (GTK2KEYDOWN=false, WIDGET=0x25c8d80, EVENT=0x28b70a0, DATA=0x7fd178b545d0) at gtk2widgetset.inc:68
#41 0x00007fd17f241938 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#42 0x00007fd17ec3525d in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#43 0x00007fd17ec4af5d in ?? () from /usr/lib/libgobject-2.0.so.0
#44 0x00007fd17ec4c48a in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#45 0x00007fd17ec4cb33 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#46 0x00007fd17f34478e in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#47 0x00007fd17f23a37d in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#48 0x00007fd17f23b3c3 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#49 0x00007fd17eebe03c in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#50 0x00007fd17e99cd4b in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#51 0x00007fd17e9a051d in ?? () from /usr/lib/libglib-2.0.so.0
#52 0x00007fd17e9a06db in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#53 0x00007fd17f23b61d in gtk_main_iteration_do () from /usr/lib/libgtk-x11-2.0.so.0
#54 0x000000000088d076 in APPWAITMESSAGE (this=0x7fd17fc6c160) at ../gtk/gtkwidgetset.inc:1253
#55 0x000000000067d4af in IDLE (WAIT=true, this=0x7fd17fc74ed0) at include/application.inc:315
#56 0x000000000067f13a in HANDLEMESSAGE (this=0x7fd17fc74ed0) at include/application.inc:985
#57 0x000000000067f4f2 in RUNLOOP (this=0x7fd17fc74ed0) at include/application.inc:1095
#58 0x00000000006f9f08 in APPRUN (ALOOP={Proc = {procedure (^pointer)} 0x7fff87e39090, Self = 0x7fd17fc74ed0}, this=0x7fd17fc6c160) at include/interfacebase.inc:49
#59 0x000000000067f494 in RUN (this=0x7fd17fc74ed0) at include/application.inc:1082
#60 0x0000000000650af2 in main () at lazarus.pp:107
backtrace (5,556 bytes)   

Renato Caldas

2008-11-04 15:57

reporter   ~0023155

This also happens with stable 0.9.26.

I'm also experiencing the problem while clicking "Edit-> Copy" or while clicking "Right Mouse Button Popup -> Copy".

I'm also on 64 bit but with gtk+-2.14.4.

alexander1

2008-11-07 09:01

reporter   ~0023200

Last edited: 2008-11-07 19:32

Same problem. I'm to in ubuntu 8.10 64bit but with the gtk2 version: 2.16.1-0ubuntu1

I can only get lazarus with gtk2 to run with the fpc from the svn and then lazarus crashes when you copy some text...

With the stable (2.2.2) fpc i get following error message while compiling lazarus (gtk2):

Linking ../lazarus
/usr/lib/fpc/2.2.2/units/x86_64-linux/gtk2/gtk2.o: In function `GTK2_GTK_FILE_SYSTEM_ERROR$$LONGWORD':
gtk2.pas:(.text+0x104ed): undefined reference to `gtk_file_system_error_quark'
/usr/lib/fpc/2.2.2/units/x86_64-linux/gtk2/gtk2.o: In function `GTK2_GTK_TYPE_FILE_INFO$$QWORD':
gtk2.pas:(.text+0x10505): undefined reference to `gtk_file_info_get_type'
/usr/lib/fpc/2.2.2/units/x86_64-linux/gtk2/gtk2.o: In function `GTK2_GTK_TYPE_FILE_SYSTEM$$QWORD':
gtk2.pas:(.text+0x1051d): undefined reference to `gtk_file_system_get_type'
/usr/lib/fpc/2.2.2/units/x86_64-linux/gtk2/gtk2.o: In function `GTK2_GTK_TYPE_FILE_FOLDER$$QWORD':
gtk2.pas:(.text+0x105b5): undefined reference to `gtk_file_folder_get_type'
lazarus.pp(122,1) Error: Error while linking
lazarus.pp(122,1) Fatal: There were 1 errors compiling module, stopping
Fatal: Compilation aborted
make[2]: *** [lazarus] Fehler 1
make[2]: Verlasse Verzeichnis '/home/alexander/Programme/lazarus/ide'
make[1]: *** [ide] Fehler 2
make[1]: Verlasse Verzeichnis '/home/alexander/Programme/lazarus/ide'
make: *** [ide] Fehler 2

daoo

2008-11-07 18:55

reporter   ~0023213

Last edited: 2008-11-07 18:57

alexander1 fpc 2.2.2 won't work due to Issue 11837 which is fixed in fpc trunk.

alexander1

2008-11-07 19:35

reporter   ~0023215

ok.. yeah I knew that.. I just added it to show that nothing (except using gtk1) gets my lazarus to compile and run without crashes...

sorry if it was to much...

Paul Ishenin

2008-11-08 10:37

manager   ~0023221

Please test and close if ok.

daoo

2008-11-09 17:27

reporter   ~0023258

Yay, works as it should now. Thanks a lot.

Issue History

Date Modified Username Field Change
2008-10-14 22:40 daoo New Issue
2008-10-14 22:40 daoo File Added: backtrace
2008-10-14 22:40 daoo Widgetset => GTK 2
2008-10-16 00:55 Ivo Steinmann Relationship added related to 0012407
2008-10-16 00:56 Vincent Snijders Relationship replaced has duplicate 0012407
2008-10-17 22:06 Vincent Snijders Relationship added child of 0008165
2008-10-17 22:06 Vincent Snijders LazTarget => 1.0
2008-10-17 22:06 Vincent Snijders Status new => acknowledged
2008-10-17 22:06 Vincent Snijders Target Version => 1.0.0
2008-11-03 20:45 Vincent Snijders Relationship added has duplicate 0012557
2008-11-04 15:57 Renato Caldas Note Added: 0023155
2008-11-07 09:01 alexander1 Note Added: 0023200
2008-11-07 18:55 daoo Note Added: 0023213
2008-11-07 18:56 daoo Note Edited: 0023213
2008-11-07 18:57 daoo Note Edited: 0023213
2008-11-07 19:32 alexander1 Note Edited: 0023200
2008-11-07 19:35 alexander1 Note Added: 0023215
2008-11-08 10:37 Paul Ishenin Fixed in Revision => 17272
2008-11-08 10:37 Paul Ishenin Status acknowledged => resolved
2008-11-08 10:37 Paul Ishenin Fixed in Version => 0.9.27 (SVN)
2008-11-08 10:37 Paul Ishenin Resolution open => fixed
2008-11-08 10:37 Paul Ishenin Assigned To => Paul Ishenin
2008-11-08 10:37 Paul Ishenin Note Added: 0023221
2008-11-09 17:27 daoo Status resolved => closed
2008-11-09 17:27 daoo Note Added: 0023258