View Issue Details

IDProjectCategoryView StatusLast Update
0000125Lazaruspublic2003-07-07 04:07
ReporterBug Import Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Summary0000125: .lpi is not a historic file
Descriptionfreepascal pre1.08
Linux

Description:

1- Create a new proyect (application).
2- Create two units called, for example, unit1 (for form1) and unit2 (no form).
3.- Save de proyect (call it proyect1) and exit.

Now, open Lazarus and Load the proyect1:
1.- Remove from proyect (Proyect->Remove form proyect) the unit2.pas
2.- Close the unit2 from Lazarus Editor
2.- Save the proyect1.

The bug: you can see into proyect1.lpi, because Lazarus do not delete the reference for the unit2. There is no problem, because the proyect run OK, but if you are programing a big application, the .lpi shows all the unit you deleted. The .lpi is a historic file????

Additional InformationImported information
--------------------
Name: mapelo
Mail: manuel.perez.lopez (at) hispalinux.es
TagsNo tags attached.
Fixed in Revision
LazTarget
WidgetsetGTK, Win32/Win64
Attached Files

Activities

Bug Import

2003-07-07 04:07

reporter   ~0000107

the .lpi file also stores session information.
You can deactivate it for the current project in Project -> Project Options -> Info.

Issue History

Date Modified Username Field Change
2003-07-07 00:00 Bug Import New Issue
2003-07-07 04:07 Bug Import Widgetset => GTK, Win32
2003-07-07 04:07 Bug Import Status new => assigned
2003-07-07 04:07 Bug Import Assigned To => Mattias Gaertner
2003-07-07 04:07 Bug Import Note Added: 0000107
2003-07-07 04:07 Bug Import Status new => closed
2003-07-07 04:07 Bug Import Resolution open => no change required