View Issue Details

IDProjectCategoryView StatusLast Update
0012572LazarusLCLpublic2013-09-03 12:07
ReporterBent Normann Olsen Assigned ToTom Gregorovic  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Fixed in Version0.9.27 (SVN) 
Summary0012572: Clicking on TPanel, TPage etc causes controls to loose focus
DescriptionWhen you place a TEdit control on a form, and an empty TPanel (or TNotebook with a TPage), compile it and run, set the input focus on TEdit control, you can click on the panel and the TEdit control loses focus - even though the TPanel don't need or want the focus.

This isn't a normal behavior on Mac or Win32, and can annoy some users, because users tend to click on anything but controls to reactivate a form - but likes to keep their input focus as they left it.
Additional InformationThis is reproducesable on Mac OS X and Win32 with Lazarus 0.9.27.
TagsNo tags attached.
Fixed in Revision17239
LazTarget1.4
WidgetsetCarbon
Attached Files

Activities

Tom Gregorovic

2008-11-05 17:29

developer   ~0023186

Should be fixed under carbon. I am not able to reproduce it under win.

Bent Normann Olsen

2008-11-06 10:46

reporter   ~0023189

Updated all Lazarus on Mac i386/PPC and Win32 to latest revision, and is good. I had an older revision on Win32, so that's why I was able to reproduce it on Win32, but it's now working nicely.

Issue History

Date Modified Username Field Change
2008-11-05 14:54 Bent Normann Olsen New Issue
2008-11-05 14:54 Bent Normann Olsen Widgetset => Win32, Carbon
2008-11-05 15:11 Vincent Snijders LazTarget => post 1.2
2008-11-05 15:11 Vincent Snijders Status new => acknowledged
2008-11-05 17:21 Tom Gregorovic Status acknowledged => assigned
2008-11-05 17:21 Tom Gregorovic Assigned To => Tom Gregorovic
2008-11-05 17:29 Tom Gregorovic Fixed in Revision => 17239
2008-11-05 17:29 Tom Gregorovic Widgetset Win32, Carbon => Carbon
2008-11-05 17:29 Tom Gregorovic Status assigned => resolved
2008-11-05 17:29 Tom Gregorovic Fixed in Version => 0.9.27 (SVN)
2008-11-05 17:29 Tom Gregorovic Resolution open => fixed
2008-11-05 17:29 Tom Gregorovic Note Added: 0023186
2008-11-06 10:46 Bent Normann Olsen Status resolved => closed
2008-11-06 10:46 Bent Normann Olsen Note Added: 0023189
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4