View Issue Details

IDProjectCategoryView StatusLast Update
0012600LazarusWidgetsetpublic2011-10-19 15:35
Reportergodknew Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version0.9.27 (SVN) 
Target Version1.0.0 
Summary0012600: input once, display twice
Descriptionmy os is Linux 2.6.25.18-0.2-default 0000001 SMP 2008-10-21 16:30:26 +0200 x86_64 x86_64 x86_64 GNU/Linux (OpenSuse)

the control which inherited from TWinControl, such as TEdit, TMemo, TSynEdit, has the same problem that when enter any key into the control, it would be display twice.

the other program on my system has ran good, I don't know what the problem is.

is this the problem about lazarus or about gtk2 configuration in my system

by the way, when choose gtk, it would be ran good.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0015185 resolvedZeljan Rikalo if envement GTK_IM_MODULE set to scim-bridge, input in lazarus is doubled 
has duplicate 0013185 resolvedBart Broersma Key presses behave strangely 

Activities

Vincent Snijders

2008-11-09 21:39

manager   ~0023270

Please, add an example application?

Are keys duplicated in the Lazarus source editor too?

godknew

2008-11-10 01:55

reporter   ~0023271

It happend when I open the Lazarus, and put any TEdit or TMemo control on the form.

The Lazarus source editor has no problem, but it could not accept the Chinese word input, so I doubt the problem is relation to my Linux configuration.

Vincent Snijders

2008-11-10 10:58

manager   ~0023281

Does it happen with Latin chars and/or Chinese chars?

godknew

2008-11-10 13:22

reporter   ~0023285

it happen with Latin chars

godknew

2008-11-12 01:14

reporter   ~0023305

I found that, when I attached the TEdit's event OnKeyDown, and assign the 0 to Key. The key I pressed will be display in the EditBox once.

Bart Broersma

2009-02-24 12:32

developer   ~0025706

On the forum it is suggested that this is related to SCIM (The Smart Common Input Method platform), once disabled the problem should disappear?
See: http://forum.lazarus.freepascal.org/index.php?topic=6231.0;topicseen

Bart Broersma

2011-10-19 15:34

developer   ~0053159

No feedback from reproter.
So I assume it indeed is a duplicate of 0015185, hence resolving this one.

Issue History

Date Modified Username Field Change
2008-11-09 15:27 godknew New Issue
2008-11-09 15:27 godknew Widgetset => GTK 2
2008-11-09 21:39 Vincent Snijders LazTarget => 1.0
2008-11-09 21:39 Vincent Snijders Note Added: 0023270
2008-11-09 21:39 Vincent Snijders Status new => feedback
2008-11-09 21:39 Vincent Snijders Target Version => 1.0.0
2008-11-10 01:55 godknew Note Added: 0023271
2008-11-10 10:58 Vincent Snijders Note Added: 0023281
2008-11-10 13:22 godknew Note Added: 0023285
2008-11-10 13:53 Vincent Snijders Status feedback => acknowledged
2008-11-12 01:14 godknew Note Added: 0023305
2009-02-24 12:32 Bart Broersma Note Added: 0025706
2009-03-07 18:29 Bart Broersma Relationship added has duplicate 0013185
2009-12-02 11:53 Bart Broersma Relationship added duplicate of 0015185
2011-10-19 15:34 Bart Broersma Duplicate ID 0 => 15185
2011-10-19 15:34 Bart Broersma Status acknowledged => resolved
2011-10-19 15:34 Bart Broersma Resolution open => duplicate
2011-10-19 15:34 Bart Broersma Assigned To => Bart Broersma
2011-10-19 15:34 Bart Broersma Note Added: 0053159