View Issue Details

IDProjectCategoryView StatusLast Update
0012792LazarusOtherpublic2013-09-03 12:07
ReporterMario Bonati Assigned ToVincent Snijders  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
PlatformAllOSAll 
Product Version0.9.27 (SVN) 
Fixed in Version0.9.27 (SVN) 
Summary0012792: Add a new switch "-version" for command line
DescriptionTo see the version of Lazarus the user must enter in IDE. More softwares have a switch "-version" that can be used from command line to see the version of the application without enter on it. Can be added this switch also for Lazarus?

Thanks, Mario
TagsNo tags attached.
Fixed in Revision19520,20327
LazTarget1.4
Widgetset
Attached Files

Activities

Vincent Snijders

2009-04-20 14:12

manager   ~0026864

I added -v and --version.

Mario Bonati

2009-05-28 16:12

reporter   ~0028101

I have 2 question:
- cannot write the version in standard output so that the version can be readed from a batch command or redirected to a file?
- cannot write also the revision SVN in the version?

Thanks, Mario

Vincent Snijders

2009-05-31 20:12

manager   ~0028182

1: no, because it is a GUI application without console and does not have a standard output, it is closed. If you recompile Lazarus as console app (passing -WC as compilation option), then the version is written to the standard output.

2. That is another feature. :-)

Vincent Snijders

2009-05-31 22:03

manager   ~0028183

The --version output now looks like:
0.9.27 beta SVN Revision: 20324M

Issue History

Date Modified Username Field Change
2008-12-13 14:18 Mario Bonati New Issue
2009-01-19 13:31 Vincent Snijders LazTarget => post 1.2
2009-01-19 13:31 Vincent Snijders Status new => acknowledged
2009-04-20 14:11 Vincent Snijders Fixed in Revision => 19520
2009-04-20 14:11 Vincent Snijders Status acknowledged => resolved
2009-04-20 14:11 Vincent Snijders Fixed in Version => 0.9.27 (SVN)
2009-04-20 14:11 Vincent Snijders Resolution open => fixed
2009-04-20 14:11 Vincent Snijders Assigned To => Vincent Snijders
2009-04-20 14:12 Vincent Snijders Note Added: 0026864
2009-05-28 16:12 Mario Bonati Status resolved => assigned
2009-05-28 16:12 Mario Bonati Resolution fixed => reopened
2009-05-28 16:12 Mario Bonati Note Added: 0028101
2009-05-31 20:12 Vincent Snijders Note Added: 0028182
2009-05-31 22:03 Vincent Snijders Fixed in Revision 19520 => 19520,20327
2009-05-31 22:03 Vincent Snijders Status assigned => resolved
2009-05-31 22:03 Vincent Snijders Resolution reopened => fixed
2009-05-31 22:03 Vincent Snijders Note Added: 0028183
2009-06-01 20:08 Mario Bonati Status resolved => closed
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4