View Issue Details

IDProjectCategoryView StatusLast Update
0012865LazarusLCLpublic2010-05-11 18:54
ReporterŽilvinas LedasAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version0.9.27 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0012865: TScrollBar repaint problem
DescriptionI got feedback that scrollBar in my program got repainted badly, so I have made test program containing only TMemo and TScrollBar and sent to the person who has this problem.

The screenshot is attached - the scrollbar "flickers" between good state and this (if I understand correctly - when mouse moves on it).

I know that test system is 64bit win vista ultimate version 6.0 build 6001: SP1.

Some steps (or something like this must be dome) to reproduce:
 - push on scrollbar;
 - push on text in memo
 - and afterwards move (push?) on scrollbar and it flickers.

I have tested on other winVista version (I can;t remember now what version was it) and it had no problem.
Tagsvista, win7, Windows 7
Fixed in Revision25157
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0011578 closedPaul Ishenin Themes (vista) TScrollbar uses unclean bitmap (doublebuffer, from previous?) 

Activities

2008-12-26 22:49

 

Untitled.jpg (13,456 bytes)
Untitled.jpg (13,456 bytes)

Martin Friebe

2008-12-27 22:12

manager   ~0024006

I observed similar issues under windows vista 32bit.
In my case it only happens to applications compiled with Manifest.
It affects buttons, and some others too.

When the mouse moves over such a component it is supposed to fade into a highlighted state. The first frame (which I believe to be supposed empty) Paints whatever was previously painted.

My *guess*: this is double buffering, and the double buffer is not cleared. this could be related to 0012816

Žilvinas Ledas

2008-12-27 22:54

reporter   ~0024009

Yes, it is compiled with manifest.
In my app only scrollbar and only scrollbar creted from TScrollbar acts strengely.

Paul Ishenin

2010-05-04 03:15

manager   ~0037212

Please test and close if ok.

Žilvinas Ledas

2010-05-11 18:54

reporter   ~0037449

Fixed. Thanks!

Issue History

Date Modified Username Field Change
2008-12-26 22:49 Žilvinas Ledas New Issue
2008-12-26 22:49 Žilvinas Ledas File Added: Untitled.jpg
2008-12-26 22:49 Žilvinas Ledas Widgetset => Win32
2008-12-27 22:12 Martin Friebe Note Added: 0024006
2008-12-27 22:23 Martin Friebe Relationship added duplicate of 0011578
2008-12-27 22:54 Žilvinas Ledas Note Added: 0024009
2009-01-19 13:52 Vincent Snijders LazTarget => 1.0
2009-01-19 13:52 Vincent Snijders Status new => acknowledged
2009-01-19 13:52 Vincent Snijders Target Version => 1.0.0
2009-01-31 10:55 Paul Ishenin Tag Attached: vista
2009-11-10 17:35 Žilvinas Ledas Tag Attached: Windows 7
2009-11-10 17:35 Žilvinas Ledas Tag Attached: win7
2010-05-04 03:15 Paul Ishenin Fixed in Revision => 25157
2010-05-04 03:15 Paul Ishenin Status acknowledged => resolved
2010-05-04 03:15 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-05-04 03:15 Paul Ishenin Resolution open => fixed
2010-05-04 03:15 Paul Ishenin Assigned To => Paul Ishenin
2010-05-04 03:15 Paul Ishenin Note Added: 0037212
2010-05-11 18:54 Žilvinas Ledas Status resolved => closed
2010-05-11 18:54 Žilvinas Ledas Note Added: 0037449