View Issue Details

IDProjectCategoryView StatusLast Update
0012981LazarusIDEpublic2018-11-18 00:35
ReporterAnton Kavalenka Assigned ToPaul Ishenin  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformAll 
Product Version0.9.27 (SVN) 
Target Version0.9.28Fixed in Version0.9.27 (SVN) 
Summary0012981: Form editor garbles WideString published properties of components
DescriptionIDE while saving form does something strange with widestring property content.
Looks like double utf8decode-ing
Steps To ReproduceInstall the attached package tc.lpk into IDE.
Create empty application.
Drop the instance of TTestClass into form.
WStr property should display: "привет - prüfung spaß gut"
Save the test application.
Close the application.
Reload the test application.
Wstr property content is now garbled.
привет - prüfung spaß gut 1
Additional InformationSeems to be it is very old bug and now it is returned.
TagsNo tags attached.
Fixed in Revision18304
LazTarget
WidgetsetGTK 2, Win32/Win64
Attached Files

Relationships

related to 0017746 resolvedJuha Manninen WideString properties not show in Inspector in Lazarus for Mac OS X 

Activities

2009-01-15 12:02

 

fpctest1.zip (1,775 bytes)

Anton Kavalenka

2009-01-15 12:08

reporter   ~0024458

Last edited: 2009-01-15 12:08

Seems to be double encoding is taken on form load.
First saving shows that in .LFM all OK.
Closing the form and loading again - brings the bug.

Zeljan Rikalo

2009-01-15 12:13

developer   ~0024459

Seen that problem on with qt too.

Paul Ishenin

2009-01-16 08:19

manager   ~0024466

Please test and close if ok.

Anton Kavalenka

2009-01-16 12:38

reporter   ~0024472

OK, nice work with code cleanup

Issue History

Date Modified Username Field Change
2009-01-15 12:02 Anton Kavalenka New Issue
2009-01-15 12:02 Anton Kavalenka File Added: fpctest1.zip
2009-01-15 12:02 Anton Kavalenka Widgetset => GTK 2, Win32
2009-01-15 12:08 Anton Kavalenka Note Added: 0024458
2009-01-15 12:08 Anton Kavalenka Note Edited: 0024458
2009-01-15 12:13 Zeljan Rikalo Note Added: 0024459
2009-01-15 14:31 Paul Ishenin Status new => assigned
2009-01-15 14:31 Paul Ishenin Assigned To => Paul Ishenin
2009-01-16 08:19 Paul Ishenin Fixed in Revision => 18304
2009-01-16 08:19 Paul Ishenin Status assigned => resolved
2009-01-16 08:19 Paul Ishenin Fixed in Version => 0.9.27 (SVN)
2009-01-16 08:19 Paul Ishenin Resolution open => fixed
2009-01-16 08:19 Paul Ishenin Note Added: 0024466
2009-01-16 08:19 Paul Ishenin Target Version => 0.9.28
2009-01-16 12:38 Anton Kavalenka Status resolved => closed
2009-01-16 12:38 Anton Kavalenka Note Added: 0024472
2018-11-18 00:35 Juha Manninen Relationship added related to 0017746