View Issue Details

IDProjectCategoryView StatusLast Update
0012998LazarusIDEpublic2010-10-23 22:04
ReporterArtyom Misko  Assigned ToPaul Ishenin  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version0.9.28Fixed in Version0.9.26.2 
Summary0012998: Crash IDE while changing Panels of StatusBar (gtk 2)
DescriptionCreate the new project. Lay down StatusBar on the form. Create some Panels on StatusBar. Keep the project. Open the kept project. At attempt of a choice of the panel through the inspector of objects it is received AV.

Message in console
TApplication.HandleException List index (19) out of bounds
  Stack trace:
  $080EE1FF
TApplication.HandleException: there was another exception during showing the first exception
  Stack trace:
  $080EE1FF
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END
TApplication.HandleException: there was another exception during showing the first exception
  Stack trace:
  $085E467C
  $085871B5
  $085946F1
  $08446B1C
  $082E45AC
  $082E4461
  $082E1D05
  $082E412F
  $082E1CBC
  $08069662
  $082DFCF3
  $08069662
  $08069662
  $0806D4E3
  $0825151A
  $0825AE54
  $0825AEB6
[TGtkWidgetSet.Destroy] WARNING: There are 14 unreleased DCs, a detailed dump follows:
[TGtkWidgetSet.Destroy] DCs: 020A5520 020A5280 020A53D0 020A5130 020A4FE0 020A4D40 006E6800
[TGtkWidgetSet.Destroy] WARNING: There are 37 unreleased GDIObjects, a detailed dump follows:
[TGtkWidgetSet.Destroy] GDIOs: 021355B0 021346B0 021343B0 02134950 021344D0 02134830 02134470
[TGtkWidgetSet.Destroy] gdiBitmap: 30
[TGtkWidgetSet.Destroy] gdiBrush: 3
[TGtkWidgetSet.Destroy] gdiFont: 1
[TGtkWidgetSet.Destroy] gdiPen: 1
[TGtkWidgetSet.Destroy] gdiRegion: 2
TagsNo tags attached.
Fixed in Revision18485
LazTarget1.0
WidgetsetGTK 2
Attached Files

Activities

Paul Ishenin

2009-01-19 09:42

manager   ~0024522

Please attach a test application and give us clear step by step instruction. I cannot reproduce for example this problem on gtk2-windows.

Paul Ishenin

2009-01-19 10:15

manager   ~0024525

even under linux (ubuntu 8.10) gtk2 I see no crash

2009-01-19 13:49

 

test.tar.gz (160,909 bytes)

Artyom Misko

2009-01-19 13:54

reporter   ~0024535

Last edited: 2009-01-28 20:08

Asplinux 14
1. Open Project from archive
2. Choose Statusbar
3. In object Inspector select Panel.
Under Windows XP no error on this project

Paul Ishenin

2009-01-29 08:06

manager   ~0024835

Please test and close if ok.

Artyom Misko

2009-01-29 22:18

reporter   ~0024868

Thanks.

Issue History

Date Modified Username Field Change
2009-01-18 19:15 Artyom Misko New Issue
2009-01-18 19:15 Artyom Misko Widgetset => GTK 2
2009-01-19 09:42 Paul Ishenin LazTarget => 1.0
2009-01-19 09:42 Paul Ishenin Note Added: 0024522
2009-01-19 09:42 Paul Ishenin Status new => feedback
2009-01-19 09:42 Paul Ishenin Target Version => 1.0.0
2009-01-19 10:15 Paul Ishenin Note Added: 0024525
2009-01-19 13:49 Artyom Misko File Added: test.tar.gz
2009-01-19 13:54 Artyom Misko Note Added: 0024535
2009-01-19 13:59 Artyom Misko Note Edited: 0024535
2009-01-28 20:08 Artyom Misko Note Edited: 0024535
2009-01-29 08:06 Paul Ishenin Fixed in Revision => 18485
2009-01-29 08:06 Paul Ishenin Status feedback => resolved
2009-01-29 08:06 Paul Ishenin Fixed in Version => 0.9.27 (SVN)
2009-01-29 08:06 Paul Ishenin Resolution open => fixed
2009-01-29 08:06 Paul Ishenin Assigned To => Paul Ishenin
2009-01-29 08:06 Paul Ishenin Note Added: 0024835
2009-01-29 08:07 Paul Ishenin Target Version 1.0.0 => 0.9.28
2009-01-29 22:18 Artyom Misko Status resolved => closed
2009-01-29 22:18 Artyom Misko Note Added: 0024868
2009-03-20 10:51 Vincent Snijders Fixed in Version 0.9.27 (SVN) => 0.9.26.2