View Issue Details

IDProjectCategoryView StatusLast Update
0001306LazarusDebuggerpublic2011-12-01 11:25
ReporterBoguslaw Brandys Assigned ToMarc Weustink  
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionunable to reproduce 
PlatformWin32OSWindows 
Product Version0.9.11 (SVN) 
Target Version1.0.0 
Summary0001306: Watches dialog freeze
DescriptionWatches dialog freeze when some strange (?) variable is watched likein attached screenshot.gdb is still running and seems to search something (?)
Maybe a bug in gdb but not sure
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0017909 closedMartin Friebe GDB Exception Message don't shows up 

Activities

2005-10-08 13:25

 

Capture-1.png (255,671 bytes)   
Capture-1.png (255,671 bytes)   

2005-10-09 07:18

 

crash.dmp (58,964 bytes)

Boguslaw Brandys

2005-10-09 07:22

developer   ~0001330

crash.dmp contains backtrace
This happen today once again because that bad watches was remembered and when I show Watches dialog it freeze my IDE and totaly slowdown my system ! To read backtrace I restarted computer because it ws locaked and I wasn't able to even kill gdb or running program ! Even if this is gdb bug we should consider some steps to avoid passing improper commands to gdb which can hang all system

Boguslaw Brandys

2007-01-18 15:43

developer   ~0010937

I cannot reproduce this however I think I'm very close what is happened because I find a way to 100 % reproduce the same exception

2007-01-18 17:20

 

test.zip (5,560 bytes)

Boguslaw Brandys

2007-01-18 17:33

developer   ~0010938

Test.zip contains sample project.To reproduce run project then click on button.
While ShowMessage is displayed use "reset debugger" menu option.AV is generated exactly in the same line like in this bugreport.That's because TDebugger is destroying while communication with gdb is not yet finished.

Martin Friebe

2010-11-19 23:36

manager   ~0043285

The AV should no longer occor with the latest version of lazarus.

Do you have a way to reproduce the frozen watch issue?

Martin Friebe

2011-01-10 02:46

manager   ~0045035

- Can't reproduce
- No feedback from reporter
- 0.9.11 is a long time ago

Therefore closing with the assumption that it is fixed in the mean time.

If it happens again, please reopen, or open new issue, with info how to reproduce. Thank you

Issue History

Date Modified Username Field Change
2005-10-08 13:25 Boguslaw Brandys New Issue
2005-10-08 13:25 Boguslaw Brandys File Added: Capture-1.png
2005-10-08 13:25 Boguslaw Brandys Widgetset => Win32
2005-10-08 16:11 Vincent Snijders Target => 1.0
2005-10-09 07:18 Boguslaw Brandys File Added: crash.dmp
2005-10-09 07:22 Boguslaw Brandys Note Added: 0001330
2007-01-18 15:43 Boguslaw Brandys Note Added: 0010937
2007-01-18 17:20 Boguslaw Brandys File Added: test.zip
2007-01-18 17:33 Boguslaw Brandys Note Added: 0010938
2008-04-24 09:57 Vincent Snijders Target Version => 1.0.0
2010-11-19 23:36 Martin Friebe Note Added: 0043285
2010-11-26 01:35 Martin Friebe Relationship added related to 0017909
2010-12-17 05:14 Martin Friebe Status assigned => feedback
2011-01-10 02:46 Martin Friebe Status feedback => resolved
2011-01-10 02:46 Martin Friebe Resolution open => unable to reproduce
2011-01-10 02:46 Martin Friebe Note Added: 0045035
2011-12-01 11:25 Marc Weustink Status resolved => closed