View Issue Details

IDProjectCategoryView StatusLast Update
0013161LazarusLCLpublic2010-08-19 13:21
ReporterSergey BulbaAssigned ToPaul Ishenin 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0013161: Moving mouse cursor over TScrollBar in Windows 7 and Windwos Vista causes blinking random bitmaps
DescriptionIf you create tform with tscrollbar on it and run application on Windows Seven or on Windows Vista, you'll see strange effects instead of animation during moving cursor over scrollbar: some random data is displayed for a little moment.

This data can be piece of other windows, or simply black area, or one of previous stage of the scrollbar (totally randomly).
Additional InformationFirst bug report about this error in Vista sp1 x64 I have received in december'08, but I haven't Vista and didn't create issue.

But several days ago I've seen it by own eyes in Windows 7 and decided to report it.
TagsNo tags attached.
Fixed in Revision25157
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0011578 closedPaul Ishenin Themes (vista) TScrollbar uses unclean bitmap (doublebuffer, from previous?) 

Activities

Paul Ishenin

2010-05-04 03:13

manager   ~0037211

Please test and close if ok.

Sergey Bulba

2010-08-19 13:21

reporter   ~0040276

just tested, all work fine now

Issue History

Date Modified Username Field Change
2009-02-13 11:47 Sergey Bulba New Issue
2009-02-13 11:47 Sergey Bulba Widgetset => Win32
2009-02-14 21:09 Vincent Snijders LazTarget => 1.0
2009-02-14 21:09 Vincent Snijders Status new => acknowledged
2009-02-14 21:09 Vincent Snijders Target Version => 1.0.0
2009-02-14 22:41 Martin Friebe Relationship added duplicate of 0011578
2010-05-04 03:13 Paul Ishenin Fixed in Revision => 25157
2010-05-04 03:13 Paul Ishenin Status acknowledged => resolved
2010-05-04 03:13 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-05-04 03:13 Paul Ishenin Resolution open => fixed
2010-05-04 03:13 Paul Ishenin Assigned To => Paul Ishenin
2010-05-04 03:13 Paul Ishenin Note Added: 0037211
2010-08-19 13:21 Sergey Bulba Status resolved => closed
2010-08-19 13:21 Sergey Bulba Note Added: 0040276