View Issue Details

IDProjectCategoryView StatusLast Update
0013185LazarusLCLpublic2011-10-19 15:37
ReporterIreyon Assigned ToBart Broersma  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Summary0013185: Key presses behave strangely
DescriptionThere is a problem with handling key presses. Everytime I press a key within a TEdit component, the letter appears twice. Doesn't matter if I do it within the IDE or within an LCL application. Only the backspace key is handled once. And another problem disturbs working: When I want to type certain special chars (e.g. ^), nothing happens. I have already checked my keyboard settings, but this did not solve that problem.
Additional InformationUsing Gnome 2.24 on Ubuntu 8.10.
Tagsgtk2, interface
Fixed in Revision
LazTarget1.0
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0012600 resolvedBart Broersma input once, display twice 
duplicate of 0015185 resolvedZeljan Rikalo if envement GTK_IM_MODULE set to scim-bridge, input in lazarus is doubled 

Activities

Ireyon

2009-02-16 17:40

reporter   ~0025472

Sorry, I forgot to mention that I use late SVN revisions of Lazarus 0.9.27.

Paul Ishenin

2009-02-17 03:21

manager   ~0025480

I have just checked with r18718 and I cannot find any problem. I have a form with TEdit and when I press key it appears only once. Also KeyPress event happens only once. Gtk2, ubuntu 8.10, gnome 2.24

Ireyon

2009-02-19 20:55

reporter   ~0025587

Noticed that this does not happen if Lazarus runs as root.

Bart Broersma

2009-03-07 18:31

developer   ~0025981

Take a look at note 0025706 in 0012600

Bart Broersma

2011-10-19 15:37

developer   ~0053160

No feedback from reporter.
The issue is most likely a duplicate of 0015185, hence resolving this one.

Issue History

Date Modified Username Field Change
2009-02-16 17:39 Ireyon New Issue
2009-02-16 17:39 Ireyon Widgetset => GTK 2
2009-02-16 17:40 Ireyon Note Added: 0025472
2009-02-17 03:21 Paul Ishenin LazTarget => -
2009-02-17 03:21 Paul Ishenin Note Added: 0025480
2009-02-17 03:21 Paul Ishenin Status new => feedback
2009-02-19 20:55 Ireyon Note Added: 0025587
2009-02-19 20:55 Ireyon Tag Attached: gtk2
2009-02-19 20:55 Ireyon Tag Attached: interface
2009-03-07 18:29 Bart Broersma Relationship added duplicate of 0012600
2009-03-07 18:31 Bart Broersma Note Added: 0025981
2009-05-06 08:53 Vincent Snijders LazTarget - => 1.0
2009-05-06 08:56 Vincent Snijders Status feedback => acknowledged
2011-10-19 15:37 Bart Broersma Relationship added duplicate of 0015185
2011-10-19 15:37 Bart Broersma Duplicate ID 0 => 15185
2011-10-19 15:37 Bart Broersma Status acknowledged => resolved
2011-10-19 15:37 Bart Broersma Resolution open => duplicate
2011-10-19 15:37 Bart Broersma Assigned To => Bart Broersma
2011-10-19 15:37 Bart Broersma Note Added: 0053160