View Issue Details

IDProjectCategoryView StatusLast Update
0013208LazarusLCLpublic2010-08-19 13:23
ReporterSergey BulbaAssigned ToPaul Ishenin 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0013208: TForm.Left is changed after showing initially invisible form
DescriptionI have system with two monitors, main monitor is right, so all X-coords are negative on left monitor. If I'll move some of application's form to left monitor and then hide it, form is "jumps" to right monitor after showing it again, i.e. Form.Left from some negative value is reset to 0.
Additional InformationTry to place on main form button.onclick "Form2.Visible := not Form2.Visible;" to ensure.

If you have not second display, you can simply move form little lefter from screen border to get Left < 0 and you'll see same "effect".
Tagsmulti-monitor
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0010330 closedPaul Ishenin misplaced code-completion hint on windows, with desktop across multi-monitor 

Activities

Paul Ishenin

2010-05-02 08:03

manager   ~0037152

Probably fixed. I can't reproduce and I remember few changes for this behavior. Please test and close if it is fixed or reopen in other case.

Stephano

2010-05-02 19:43

developer   ~0037173

I can produce this effect on GTK2 with a single monitor. Move the form slightly outside the monitor to the left, save all and reopen the project. The form will have Left=0
Lazarus 0.9.29 r25141M FPC 2.4.0 i386-linux-gtk 2 (beta)

Sergey Bulba

2010-08-19 13:23

reporter   ~0040277

Seems, all right now, thanks

Issue History

Date Modified Username Field Change
2009-02-19 11:05 Sergey Bulba New Issue
2009-02-19 11:05 Sergey Bulba Widgetset => Win32
2009-04-07 11:31 Paul Ishenin LazTarget => 1.0
2009-04-07 11:31 Paul Ishenin Status new => acknowledged
2009-04-07 11:31 Paul Ishenin Target Version => 1.0.0
2009-04-07 11:31 Paul Ishenin Relationship added related to 0010330
2009-04-07 11:37 Paul Ishenin Tag Attached: multi-monitor
2010-05-02 08:03 Paul Ishenin Status acknowledged => resolved
2010-05-02 08:03 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-05-02 08:03 Paul Ishenin Resolution open => fixed
2010-05-02 08:03 Paul Ishenin Assigned To => Paul Ishenin
2010-05-02 08:03 Paul Ishenin Note Added: 0037152
2010-05-02 19:43 Stephano Note Added: 0037173
2010-08-19 13:23 Sergey Bulba Status resolved => closed
2010-08-19 13:23 Sergey Bulba Note Added: 0040277