View Issue Details

IDProjectCategoryView StatusLast Update
0013243LazarusDatabasepublic2011-12-01 10:24
Reporterandtag Assigned ToVincent Snijders  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version0.9.27 (SVN) 
Target Version1.0.0 
Summary0013243: DbCalendar don't give date calling hide
DescriptionLazarus 0.9.27 beta SVN 18800 under Linux only (Ubuntu 8.04).
The bug is visible using these steps:

- DbCalendar is hidden on default.
- I have a DbEdit field. On DbEdit.OnEnter event i call DbCalendar.Show
then i click on a day in the calendar
- if in the DbEdit.OnExit i put DbCalendar.Hide the date give me an empty string (DbCalendar.Date) but work well not using "DbCalendar.Hide"
- in the DbEdit.Onchange event i can call DbCalendar.Hide and the Date string is ok.

Same code under windows work well.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK 2
Attached Files

Activities

andtag

2009-02-26 01:08

reporter   ~0025741

sorry, forgot to say: the empty string is on the DbCalendar.OnClick event!!

Felipe Monteiro de Carvalho

2010-07-21 10:51

developer   ~0039547

Please attach a test project

Vincent Snijders

2010-10-28 17:35

manager   ~0042268

No feedback from reporter.

Issue History

Date Modified Username Field Change
2009-02-26 00:58 andtag New Issue
2009-02-26 00:58 andtag Widgetset => GTK 2
2009-02-26 01:08 andtag Note Added: 0025741
2009-04-16 12:05 Vincent Snijders LazTarget => 1.0
2009-04-16 12:05 Vincent Snijders Status new => acknowledged
2009-04-16 12:05 Vincent Snijders Target Version => 1.0.0
2010-07-21 10:51 Felipe Monteiro de Carvalho Note Added: 0039547
2010-07-21 10:51 Felipe Monteiro de Carvalho Status acknowledged => feedback
2010-10-28 17:35 Vincent Snijders Status feedback => resolved
2010-10-28 17:35 Vincent Snijders Resolution open => unable to reproduce
2010-10-28 17:35 Vincent Snijders Assigned To => Vincent Snijders
2010-10-28 17:35 Vincent Snijders Note Added: 0042268
2011-12-01 10:24 Marc Weustink Status resolved => closed