View Issue Details

IDProjectCategoryView StatusLast Update
0013266LazarusLCLpublic2011-12-01 11:23
ReporterR.D.Assigned ToMarc Weustink 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0013266: Improper painting of PNG picture
Descriptionloading png picture in Example\imgview, and it painting incorrect
TagsNo tags attached.
Fixed in Revisionr25258
LazTarget1.0
Widgetset
Attached Files

Activities

2009-03-02 15:42

 

Dragon.png (10,685 bytes)
Dragon.png (10,685 bytes)

Boguslaw Brandys

2009-05-04 22:05

developer   ~0027299

What a strange file ! it looks differently in any program I use : in paint, in firefox in infranview - in each image is different!

Marc Weustink

2009-05-05 10:59

administrator   ~0027318

Last edited: 2009-05-05 11:00

The image is transparent, you might see a different background.

Nice image btw, i'll add it to my testset

2009-07-17 22:04

 

imgview_dragon.gif (12,531 bytes)
imgview_dragon.gif (12,531 bytes)

samuel herzog

2009-07-17 22:06

developer   ~0029154

With today's version on win32 with example project imgview it looks like this. (see upload imgview_dragon.gif).
Some how it looks like the negative of the original example.

Zeljan Rikalo

2010-05-02 19:33

developer   ~0037171

I've seen under qt that png's looks strange (more lighter than it should be).
My png's are usual kde icons (16x16) in TImageList.

Marc Weustink

2010-05-07 02:25

administrator   ~0037337

Last edited: 2010-05-07 02:26

There are 2 bugs involved. When an rawimage was read as grayscale, the alpha channels was discarded by the LazIntfImage. I fixed that.
The second bug is fpimage related. When reading gray+alpha, then channels are swapped, so you get alpha+gray that gives the inverted look. I'll try to fix this

Paul Ishenin

2010-05-07 05:45

manager   ~0037341

The next lazarus version will depend on new fpc version. So it is ok to depend your future fix.

Marc Weustink

2010-05-08 20:03

administrator   ~0037371

You also need a fpc version later than 2.4.0

Issue History

Date Modified Username Field Change
2009-03-02 15:42 R.D. New Issue
2009-03-02 15:42 R.D. File Added: Dragon.png
2009-03-02 15:42 R.D. Widgetset => Win32
2009-04-16 13:57 Vincent Snijders LazTarget => 1.0
2009-04-16 13:57 Vincent Snijders Status new => acknowledged
2009-04-16 13:57 Vincent Snijders Target Version => 1.0.0
2009-05-04 22:05 Boguslaw Brandys Note Added: 0027299
2009-05-05 10:59 Marc Weustink Note Added: 0027318
2009-05-05 11:00 Marc Weustink Note Edited: 0027318
2009-07-17 22:04 samuel herzog File Added: imgview_dragon.gif
2009-07-17 22:06 samuel herzog Note Added: 0029154
2010-05-02 16:49 Marc Weustink Status acknowledged => assigned
2010-05-02 16:49 Marc Weustink Assigned To => Marc Weustink
2010-05-02 19:33 Zeljan Rikalo Note Added: 0037171
2010-05-07 02:25 Marc Weustink Note Added: 0037337
2010-05-07 02:26 Marc Weustink Note Edited: 0037337
2010-05-07 05:45 Paul Ishenin Note Added: 0037341
2010-05-08 20:03 Marc Weustink Fixed in Revision => r25258
2010-05-08 20:03 Marc Weustink Widgetset Win32/Win64 =>
2010-05-08 20:03 Marc Weustink Status assigned => resolved
2010-05-08 20:03 Marc Weustink Fixed in Version => 0.9.29 (SVN)
2010-05-08 20:03 Marc Weustink Resolution open => fixed
2010-05-08 20:03 Marc Weustink Note Added: 0037371
2011-12-01 11:23 Marc Weustink Status resolved => closed