View Issue Details

IDProjectCategoryView StatusLast Update
0001331LazarusIDEpublic2011-12-01 11:26
ReporterAles KatonaAssigned ToMarc Weustink 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformAnyOSAnyOS VersionAny
Product VersionProduct Build 
Target VersionFixed in Version0.9.30 
Summary0001331: Put all debug windows in one TNoteBook
DescriptionDebugging in Lazarus is a PITA even when the debugger happens to be working because all the debug windows require big place and there are many of them. Why not putting all debug windows in one with a TNoteBook? So switching between locals and call stack would be a breeze.
Tagsdocking
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0001129 closedVincent Snijders debug windows could pop up automatically when exception takes place 

Activities

Marc Weustink

2008-03-29 11:40

administrator   ~0018475

Note to self: Close this issue when docking is fully operational

Martin Friebe

2011-04-28 11:24

manager   ~0047864

Since Version 0.9.30 Lazarus supports docking.

Go to packages and install AnchorDockingDsgn package or EasyDockManagerDsgn.

Issue History

Date Modified Username Field Change
2005-10-12 05:46 Ales Katona New Issue
2005-10-12 05:46 Ales Katona Widgetset => GTK
2005-10-12 05:54 Vincent Snijders Target => post 1.0
2005-10-12 05:54 Vincent Snijders Status new => acknowledged
2008-03-29 11:39 Marc Weustink Status acknowledged => assigned
2008-03-29 11:39 Marc Weustink Assigned To => Marc Weustink
2008-03-29 11:40 Marc Weustink Note Added: 0018475
2008-04-05 04:41 Felipe Monteiro de Carvalho Relationship added related to 0001129
2011-03-18 10:19 Paul Ishenin Tag Attached: docking
2011-04-28 11:24 Martin Friebe LazTarget post 1.0 => -
2011-04-28 11:24 Martin Friebe Widgetset GTK =>
2011-04-28 11:24 Martin Friebe Status assigned => resolved
2011-04-28 11:24 Martin Friebe Fixed in Version => 0.9.30
2011-04-28 11:24 Martin Friebe Resolution open => fixed
2011-04-28 11:24 Martin Friebe Note Added: 0047864
2011-12-01 11:26 Marc Weustink Status resolved => closed