View Issue Details

IDProjectCategoryView StatusLast Update
0013373FPCCompilerpublic2010-11-13 21:27
ReporterMarco van de VoortAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version2.6.0 
Summary0013373: Delphi supports "deprecated" and "platform" (and maybe more) for units.
DescriptionSyntax

unit something deprecated;

interface
...

A semi colon between something and deprecated is not allowed.

Maybe these should have an extension with a message that can be inserted to the compiler warning/message ? I saw a remark about such extension somewhere , but don't if was a feature of a newer Delphi, or just a suggestion to do so:

unit something platform 'replaced by unit xxx';

The extension could be used to make a difference between e.g. units specific to a platform and to a group of platforms (e.g. Unix)
TagsNo tags attached.
Fixed in Revision14767
FPCOldBugId0
FPCTarget
Attached Files

Activities

Inoussa OUEDRAOGO

2009-04-22 11:44

reporter   ~0026927

At least Delphi 2009 allow a message for the "deprecated" keyword. Example at
http://docs.embarcadero.com/products/rad_studio/delphiAndcpp2009/HelpUpdate2/EN/html/delphivclwin32/System_vmtAddRef.html

Marco van de Voort

2009-05-16 13:16

manager   ~0027628

Last edited: 2009-09-28 12:53

D2006 doesn't have this yet (also adding a message), but for me it is a must have.

Marco van de Voort

2010-03-06 13:22

manager   ~0034970

Last edited: 2010-03-06 13:35

Apparantly done mostly by Paul in r14767

library,deprecated,experimental,platform and unimplemented are consumed, only deprecated takes an message argument, and using a deprecated unit works.

Paul Ishenin

2010-03-09 03:15

developer   ~0035056

It is already implemented in the trunk. Is something more is needed then provide a test.

Marco van de Voort

2010-03-10 22:41

manager   ~0035210

I left it open because of the

unit something platform 'replaced by unit xxx';

interface

implementation

end.

remark. But it is a feature, not delphi compat.

Issue History

Date Modified Username Field Change
2009-03-21 12:58 Marco van de Voort New Issue
2009-03-21 12:58 Marco van de Voort FPCOldBugId => 0
2009-03-21 13:08 Marco van de Voort Description Updated
2009-04-22 10:08 Marco van de Voort Description Updated
2009-04-22 11:44 Inoussa OUEDRAOGO Note Added: 0026927
2009-05-16 13:16 Marco van de Voort Note Added: 0027628
2009-06-01 11:17 Marco van de Voort Note Edited: 0027628
2009-09-28 12:53 Marco van de Voort Note Edited: 0027628
2010-03-06 13:22 Marco van de Voort Note Added: 0034970
2010-03-06 13:35 Marco van de Voort Note Edited: 0034970
2010-03-06 13:35 Marco van de Voort Note Edited: 0034970
2010-03-06 13:35 Marco van de Voort Fixed in Revision => 14767
2010-03-09 03:15 Paul Ishenin Status new => resolved
2010-03-09 03:15 Paul Ishenin Fixed in Version => 2.5.1
2010-03-09 03:15 Paul Ishenin Resolution open => fixed
2010-03-09 03:15 Paul Ishenin Assigned To => Paul Ishenin
2010-03-09 03:15 Paul Ishenin Note Added: 0035056
2010-03-10 22:41 Marco van de Voort Note Added: 0035210
2010-11-13 21:27 Jonas Maebe Status resolved => closed