View Issue Details

IDProjectCategoryView StatusLast Update
0013433LazarusLCLpublic2009-04-04 19:25
ReporterWimpie Nortje Assigned ToAlexander S. Klenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.26 
Target Version1.0.0Fixed in Version0.9.28 
Summary0013433: TAChart left axis makes room for axis labels when LeftAxis.Visible := false
DescriptionWhen TAChart.LeftAxis.Visible := false the axis moves to make space to display the axis values. If LeftAxis.Visible = false, the left axis should not move, regardless of the size of the axis values.
TagsNo tags attached.
Fixed in Revision19189
LazTarget1.0
Widgetset
Attached Files

Activities

Vincent Snijders

2009-03-31 14:55

manager   ~0026473

Maybe already fixed? There have been a lot of changes in TAChart since 0.9.26.

Alexander S. Klenin

2009-03-31 15:22

developer   ~0026474

I can not reproduce, and AFAIR it was working correctly before my changes too.
Please test SVN version and/or provide screenshots, preferably by using demo
program supplied with TAChart component.

Note that some space (5 pixels) around the borders is reserved
unconditionally (which perhaps is a bad idea).

Alexander S. Klenin

2009-04-01 21:10

developer   ~0026519

I managed to reproduce the issue.
It was caused by complicated interactions of chart element positioning routines.
After some investigating I decided to just rewrite the whole mess.
Please check and close if ok.
(and open another issues if you find any regression).

Wimpie Nortje

2009-04-04 19:25

reporter   ~0026606

Tested svn 19219M.
Problems is fixed

Issue History

Date Modified Username Field Change
2009-03-31 14:49 Wimpie Nortje New Issue
2009-03-31 14:49 Wimpie Nortje Widgetset => GTK
2009-03-31 14:55 Vincent Snijders LazTarget => 1.0
2009-03-31 14:55 Vincent Snijders Note Added: 0026473
2009-03-31 14:55 Vincent Snijders Assigned To => Alexander S. Klenin
2009-03-31 14:55 Vincent Snijders Status new => assigned
2009-03-31 14:55 Vincent Snijders Target Version => 1.0.0
2009-03-31 15:22 Alexander S. Klenin Note Added: 0026474
2009-04-01 21:10 Alexander S. Klenin Fixed in Revision => 19189
2009-04-01 21:10 Alexander S. Klenin Widgetset GTK =>
2009-04-01 21:10 Alexander S. Klenin Status assigned => resolved
2009-04-01 21:10 Alexander S. Klenin Fixed in Version => 0.9.28
2009-04-01 21:10 Alexander S. Klenin Resolution open => fixed
2009-04-01 21:10 Alexander S. Klenin Note Added: 0026519
2009-04-04 19:25 Wimpie Nortje Status resolved => closed
2009-04-04 19:25 Wimpie Nortje Note Added: 0026606