View Issue Details

IDProjectCategoryView StatusLast Update
0013572LazarusIDEpublic2009-07-28 19:41
ReporterVladimir Zhirov Assigned ToJesus Reyes  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version1.0.0Fixed in Version0.9.27 (SVN) 
Summary0013572: Localization problem - nonlocalizable items
DescriptionAll of the below items are either immune to changes in localization files or does not have corresponding values in these files.

1. Environment options categories (immune to localization):
 - Environment
 - Editor
 - Codetools
 - Code Explorer
 - Debugger

2. CheckListBox items in "Code Folding" frame of the Options dialog ("Unit section", "Nested comment")

3. ListBox items in "Color" frame of the Options dialog ("Assembler", "Bracket Highlight", etc.)
TagsNo tags attached.
Fixed in Revision20985, 20987
LazTarget1.0
Widgetset
Attached Files

Relationships

parent of 0014217 closedJesus Reyes Inexplicably translated strings remains as originals in Environment Options Dialog 

Activities

Vladimir Zhirov

2009-04-23 18:23

reporter   ~0026996

One more example is TreeView items in "File -> New..." dialog.

Maxim Ganetsky

2009-04-23 22:21

developer   ~0027005

Last edited: 2009-04-24 02:47

"Code Folding" frame is fully translated since rev 19592.

Vladimir Zhirov

2009-04-24 20:27

reporter   ~0027042

The CheckListBox in in "Code Folding" frame still has non translated items, such as
 - "Unit section"
 - "Nested comment"
 - "(nested)", "(local)", "(global)"

The problem is, the .po file is ok, it has all strings translated, but the GUI shows English text instead of translated one.

Vladimir Zhirov

2009-04-24 21:53

reporter   ~0027045

Last edited: 2009-04-24 21:54

I found the cause of the problem:

1. Environment options categories are loaded during units initialization. Translated strings are not available at that moment. See
  line 1486 of ide\environmentopts.pp,
  line 3069 of ide\editoroptions.pp,
  line 723 of ide\codetoolsoptions.pas,
  line 733 of ide\codeexplopts.pas,
  line 174 of ide\basedebugmanager.pas.

2. CheckListBox items in "Code Folding" are put into const array (see line 408 of ide\editoroptions.pp). Obviously, translated strings are not available at the constants evaluation time.

3. ListBox items in "Color" frame (ColorElementListBox in ide\frames\editor_color_options.pas) contains SynEdit attribute names that are not localizable (line 699 of ide\frames\editor_color_options.pas)

4. TreeView items in "File -> New..." dialog are localized but overriden with English-only string constants in ide\mainintf.pas from the line 408 on (see GetLocalizedName methods).

Marcelo B Paula

2009-07-28 03:07

reporter   ~0029300

I observed these same errors.
I did some research on "File -> New" dialog case, and found that constants are in projectinf.pas (almost). I did some tests, translating these strings and confirmed that they are used in newdialog.
The problem is the same related here before. This unit is loaded prior to translate functions. So even putting them in a rst like objinspstrconsts, they are not translated.

Jesus Reyes

2009-07-28 09:13

developer   ~0029310

Points 1,2 and 3 should now be fixed.

Please create separated reports for additional issues because even when they seems related not all problems are trivial to fix (that is the case of 4), If we continue to add items to this issue it gets boring, bad if you do things for fun.

So please submit a new report for point 4.

Marcelo B Paula

2009-07-28 14:05

reporter   ~0029326

OK. I´ll create a new bug for point 4.

Vladimir Zhirov

2009-07-28 19:41

reporter   ~0029339

Thanks, Jesus.

I'm sorry for adding several bugs into one report.

Issue History

Date Modified Username Field Change
2009-04-23 18:10 Vladimir Zhirov New Issue
2009-04-23 18:23 Vladimir Zhirov Note Added: 0026996
2009-04-23 22:21 Maxim Ganetsky Note Added: 0027005
2009-04-24 02:47 Maxim Ganetsky Note Edited: 0027005
2009-04-24 20:27 Vladimir Zhirov Note Added: 0027042
2009-04-24 21:53 Vladimir Zhirov Note Added: 0027045
2009-04-24 21:54 Vladimir Zhirov Note Edited: 0027045
2009-04-27 12:08 Vincent Snijders LazTarget => 1.0
2009-04-27 12:08 Vincent Snijders Status new => acknowledged
2009-04-27 12:08 Vincent Snijders Target Version => 1.0.0
2009-07-28 03:07 Marcelo B Paula Note Added: 0029300
2009-07-28 06:00 Jesus Reyes Status acknowledged => assigned
2009-07-28 06:00 Jesus Reyes Assigned To => Jesus Reyes
2009-07-28 06:01 Jesus Reyes Relationship added parent of 0014217
2009-07-28 09:13 Jesus Reyes Fixed in Revision => 20985, 20987
2009-07-28 09:13 Jesus Reyes Status assigned => resolved
2009-07-28 09:13 Jesus Reyes Fixed in Version => 0.9.27 (SVN)
2009-07-28 09:13 Jesus Reyes Resolution open => fixed
2009-07-28 09:13 Jesus Reyes Note Added: 0029310
2009-07-28 14:05 Marcelo B Paula Note Added: 0029326
2009-07-28 19:41 Vladimir Zhirov Status resolved => closed
2009-07-28 19:41 Vladimir Zhirov Note Added: 0029339