View Issue Details

IDProjectCategoryView StatusLast Update
0013676LazarusIDEpublic2011-12-01 11:23
ReporterBambang PranotoAssigned ToPaul Ishenin 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.26.2Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0013676: Problem with visual form inheritance for form contains frame.
DescriptionSteps to reproduce:

1. Create a form Form1
2. Create a frame Frame1 contains a button
3. Place Frame1 onto Form1
4. Create form Form2 descended from Form1 through File -> New .. ->
Inherited Items
5. Change something on Form2 like repositioning the frame.

Compile and run, when Form2 shows up an error message will be poped
up: Project raised exception class "EComponentError" with message:
Duplicate name: A Component named "Frame1_1" already exists.

The problem lies in the .lfm file which generated as follows:

inherited Form2: TForm2
 Left = 452
 Top = 67
 Caption = 'Form2'
 inline Frame1_1: TFrame1 ==> HERE IS THE BUG
   Left = 48
   Top = 96
   Visible = True
   inherited Button1: TButton
   end
 end
end

if I change "inline Frame1_1: TFrame1" to "inherited Frame1_1:
TFrame1" everything goes well. However, there are still some problems:

1. I can't display the .lfm file as Form, lazarus complains class
TFrame1 is not found. Manually adding Frame1 to uses clause of
unit2.pas solves the problem.

2. As soon you change anything in Form2, the wrong "inline Frame1_1:
TFrame1" always comes back again.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0013445 closedPaul Ishenin Tframe and inherited of form 

Activities

nicola gorlandi

2009-05-08 09:00

reporter   ~0027443

I've report the same bug as number 0013445.

Paul Ishenin

2010-05-10 06:09

manager   ~0037407

Probably fpc 2.5.1 is required at the moment.

Please test and close if ok.

Issue History

Date Modified Username Field Change
2009-05-08 05:17 Bambang Pranoto New Issue
2009-05-08 05:17 Bambang Pranoto Widgetset => Win32
2009-05-08 08:41 Vincent Snijders LazTarget => 1.0
2009-05-08 08:41 Vincent Snijders Status new => acknowledged
2009-05-08 08:41 Vincent Snijders Target Version => 1.0.0
2009-05-08 08:41 Vincent Snijders Severity block => major
2009-05-08 09:00 nicola gorlandi Note Added: 0027443
2009-05-08 09:30 Vincent Snijders Relationship added duplicate of 0013445
2010-05-10 06:09 Paul Ishenin Status acknowledged => resolved
2010-05-10 06:09 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-05-10 06:09 Paul Ishenin Resolution open => fixed
2010-05-10 06:09 Paul Ishenin Assigned To => Paul Ishenin
2010-05-10 06:09 Paul Ishenin Note Added: 0037407
2011-12-01 11:23 Marc Weustink Status resolved => closed