View Issue Details

IDProjectCategoryView StatusLast Update
0013710LazarusIDEpublic2009-10-23 00:40
ReporterDenis Gottardello Assigned ToVincent Snijders  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.26.2 
Fixed in Version0.9.27 (SVN) 
Summary0013710: Adding files to project from another directory.
DescriptionI have added some files from another directory to the project but at the build I obtain an error. The compliler does not find files.
Additional InformationDebian 5 (Lenny), I386, Lazarus 0.9.26-2
TagsNo tags attached.
Fixed in Revision20728
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0007740 closedMattias Gaertner Project inspector should ask to add new directories to include or unit path 

Activities

Vincent Snijders

2009-05-15 16:23

manager   ~0027618

Did you add the path of the 'another directory' to the compiler options, unit path?

Denis Gottardello

2009-05-18 10:49

reporter   ~0027701

If I add the directory's path to the compiler options works well. In Delphi just add the pas to the procject. Do you think it was a good idea to implement this in Lazarus?

Vincent Snijders

2009-05-18 10:54

manager   ~0027702

It is a good idea.

Vincent Snijders

2009-06-24 12:32

manager   ~0028710

Last edited: 2009-06-24 12:33

The question is asked when you choose Project -> Add editor file to project.

It is not yet asked when you add files in the Project Inspector.

How did you add the files to the project?

Issue History

Date Modified Username Field Change
2009-05-14 11:04 Denis Gottardello New Issue
2009-05-14 11:04 Denis Gottardello Widgetset => GTK 2
2009-05-15 16:23 Vincent Snijders Note Added: 0027618
2009-05-15 16:23 Vincent Snijders LazTarget => 1.0
2009-05-15 16:23 Vincent Snijders Status new => feedback
2009-05-15 16:23 Vincent Snijders Target Version => 1.0.0
2009-05-18 10:49 Denis Gottardello Note Added: 0027701
2009-05-18 10:54 Vincent Snijders Note Added: 0027702
2009-05-18 10:54 Vincent Snijders Severity minor => feature
2009-05-18 10:54 Vincent Snijders Status feedback => acknowledged
2009-05-18 10:54 Vincent Snijders Target Version 1.0.0 =>
2009-05-18 10:54 Vincent Snijders LazTarget 1.0 => -
2009-05-18 10:56 Vincent Snijders Relationship added duplicate of 0007740
2009-06-24 12:32 Vincent Snijders Note Added: 0028710
2009-06-24 12:32 Vincent Snijders Status acknowledged => feedback
2009-06-24 12:33 Vincent Snijders Note Edited: 0028710
2009-06-24 14:16 Vincent Snijders Fixed in Revision => 20728
2009-06-24 14:16 Vincent Snijders Status feedback => resolved
2009-06-24 14:16 Vincent Snijders Fixed in Version => 0.9.27 (SVN)
2009-06-24 14:16 Vincent Snijders Resolution open => fixed
2009-06-24 14:16 Vincent Snijders Assigned To => Vincent Snijders
2009-10-23 00:40 Marc Weustink Status resolved => closed