View Issue Details

IDProjectCategoryView StatusLast Update
0013719LazarusLCLpublic2009-10-23 00:40
ReporterA.J. Vogelaar Assigned ToVincent Snijders  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version1.0.0Fixed in Version0.9.27 (SVN) 
Summary0013719: Slow button response (GTK2 on Linux)
DescriptionOn a Tform is a TFrame.
This TFrame contains a TPageControl with two TTabsheet.
The second TTabSheet contain a TButton and a TShape.
The OnClick event of the button changes the colur of the shape.brush.

The response of pressing the button is sometimes very slow, up to 5 seconds on a 2.4 GHz machine running Mandriva 2009.1
TagsNo tags attached.
Fixed in Revision
LazTarget1.0
WidgetsetGTK 2
Attached Files

Activities

A.J. Vogelaar

2009-05-15 14:06

reporter   ~0027608

There is a similar slow response on changing tabs.

Vincent Snijders

2009-05-15 14:15

manager   ~0027610

With what revision number of Lazarus 0.9.27 did you test? r19967 might have some improvements.

Reinhard Berger

2009-05-16 05:53

reporter   ~0027624

Close the IDE and execute the program again, i'm sure it will speed up.

I don't know why, but as long as the program runs from the IDE everything is slower.

Vincent Snijders

2009-06-17 23:09

manager   ~0028593

Can you upload the test application?

Anton Kavalenka

2009-06-18 19:31

reporter   ~0028617

IMO this had been fixed month ago or so.
This was caused by unnecessary walking deep into controls tree in
Widgetset's WindowFromPoint() implementation

Vincent Snijders

2009-08-03 14:17

manager   ~0029491

No feedback from reporter. Probably fixed already.

Issue History

Date Modified Username Field Change
2009-05-15 14:01 A.J. Vogelaar New Issue
2009-05-15 14:01 A.J. Vogelaar Widgetset => GTK 2
2009-05-15 14:06 A.J. Vogelaar Note Added: 0027608
2009-05-15 14:15 Vincent Snijders LazTarget => 1.0
2009-05-15 14:15 Vincent Snijders Note Added: 0027610
2009-05-15 14:15 Vincent Snijders Status new => feedback
2009-05-15 14:15 Vincent Snijders Target Version => 1.0.0
2009-05-16 05:53 Reinhard Berger Note Added: 0027624
2009-06-17 23:09 Vincent Snijders Note Added: 0028593
2009-06-18 19:31 Anton Kavalenka Note Added: 0028617
2009-08-03 14:17 Vincent Snijders Status feedback => resolved
2009-08-03 14:17 Vincent Snijders Fixed in Version => 0.9.27 (SVN)
2009-08-03 14:17 Vincent Snijders Resolution open => fixed
2009-08-03 14:17 Vincent Snijders Assigned To => Vincent Snijders
2009-08-03 14:17 Vincent Snijders Note Added: 0029491
2009-10-23 00:40 Marc Weustink Status resolved => closed