View Issue Details

IDProjectCategoryView StatusLast Update
0013768LazarusDatabasepublic2011-07-06 15:12
ReporterSebastian Gasiorek Assigned ToJesus Reyes  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version1.0.0 
Summary0013768: sigsegv while displaying image from sqlite database with tdbimage
DescriptionWhen you try to load image from sqlite UTF-16 database sigsegv occurs.

I have created small example with UTF-8 (working) and UTF-16 database (crash).
TagsNo tags attached.
Fixed in Revision17732?
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0017663 resolvedMichael Van Canneyt FPC TDBImage Bugs 

Activities

2009-05-20 13:07

 

test_image.zip (941,763 bytes)

Paul Ishenin

2010-07-12 09:14

manager   ~0039283

It does not crash since the revision 26606 but also does not load the picture. Did you open the issues only because of crash or you need to load the picture from an utf-16 database?

Marco van de Voort

2011-07-06 15:12

manager   ~0049728

For me it now works (fpc 2.5.1, lazarus/trunk) Both button 1 and 2 show the cheetah.

Possibly related to

r17732 | marco | 2011-06-12 17:34:43 +0200 (Sun, 12 Jun 2011) | 3 lines

 * Committed patch from LacaK2 that adds some SQL unicode fieldtypes for sqlite3
    Mantis 0018670

Issue History

Date Modified Username Field Change
2009-05-20 13:07 Sebastian Gasiorek New Issue
2009-05-20 13:07 Sebastian Gasiorek File Added: test_image.zip
2009-05-20 13:07 Sebastian Gasiorek Widgetset => Win32
2009-05-20 13:30 Vincent Snijders LazTarget => 1.0
2009-05-20 13:30 Vincent Snijders Status new => acknowledged
2009-05-20 13:30 Vincent Snijders Target Version => 1.0.0
2010-05-01 16:31 Paul Ishenin Assigned To => Jesus Reyes
2010-05-01 16:31 Paul Ishenin Category LCL => Database
2010-07-12 09:14 Paul Ishenin Note Added: 0039283
2010-07-12 09:14 Paul Ishenin Status acknowledged => feedback
2010-10-29 08:17 Vincent Snijders Relationship added related to 0017663
2011-07-06 15:12 Marco van de Voort Fixed in Revision => 17732?
2011-07-06 15:12 Marco van de Voort Status feedback => resolved
2011-07-06 15:12 Marco van de Voort Resolution open => fixed
2011-07-06 15:12 Marco van de Voort Note Added: 0049728