View Issue Details

IDProjectCategoryView StatusLast Update
0013790Lazarus CCRglscenepublic2009-09-03 19:48
ReporterKjowAssigned ToVincent Snijders 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Summary0013790: GLScene problem on latest builds & Windows 7
DescriptionThe Problem: compiling a project that uses GLScene cause the exe project will close itself instantly!

I recently upgraded to Windows 7 RC (some hardware drivers work on Win7 x64,
but not in Vista x64!), but I have some problems to use GLScene with
Lazarus+GLScene (1.0.0.3 - revision: 2291).

Some hope to use latest builds on Windows 7? :)

Thank you!
Additional Informationa) If I compile with latest Lazarus snapshot it doesn't work, but if I use an old build(02/23/2009 - my latest download with fpc 2.2.3) it works great.
I tried to use the build 18800 with latest fpc 2.2.5 (downloaded within today lazarus snaphot) and it works.
So, is there a recent bug introduced in lazarus development?

b) For a try, just double click in GLScene component and build project.

c) Same things in Notebook (Core 2 Duo T7600) than Desktop (Core i7 920) on Windows 7 64Bit, Lazarus and FPC 32Bit

IMPORTANT:

I reduced the range, but I can't do better why I haven't any more builds:

- Lazarus build 19814 (05/06/2009) + fpc 2.2.5 : doesn't work
- Lazarus build 19499 (19/04/2009) + fpc 2.2.5 : works
TagsEXTERNAL, GetSysColor, GLScene, SIGSEGV, Windows 7
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0013899 closedMattias Gaertner Lazarus GLScene units added in the wrong place in the uses section 

Activities

Vincent Snijders

2009-05-22 22:04

administrator   ~0027883

I set a Lazarus Target even though it is a non-core package, because it seems to be a regression and I don't know if it is intentional and requires a GLScene fix or is unintentional and needs to be fixed in Lazarus/LCL.

Kjow

2009-05-25 19:15

reporter   ~0027974

Last edited: 2009-05-25 19:17

I tried GLScene revision 2290 of 04/04/2009 (instead latest 2291).
I backupped it before Lazarus build 19499 (19/04/2009) came out and it doesn't work with latest Lazarus buils >= 19814.
It is the same as 2291.

So GLScene doesn't work with recent Lazarus snapshot, but it worked until Lazarus build 19499.

So I think that is changed something in Lazarus than GLScene.

PS: please modify "Reproducibility" in "Always"

PPS: I'm sorry about my poor english, I hope that is clearly enought

2009-06-02 19:27

 

Laz19499.zip (1,597,860 bytes)

2009-06-02 19:27

 

Laz20339.zip (1,599,389 bytes)

2009-06-02 19:28

 

Immagine.png (21,430 bytes)
Immagine.png (21,430 bytes)

2009-06-02 19:28

 

Immagine2.png (62,063 bytes)
Immagine2.png (62,063 bytes)

Kjow

2009-06-02 19:47

reporter   ~0028232

Last edited: 2009-06-02 19:49

Hi again,

I attached these 4 files:

1 & 2) Lazarus projects (with only a Button and the GLScene component inserted) respectively made with build 19499 and today snapshot 20339

3 & 4) Today I tried to enable debug mode (I'm sorry, but I haven't thought to this before) and these are the screenshots of exception: "EXTERNAL: SIGSEGV"

It seems to be a problem in winapi.inc -> getsyscolor

Vincent Snijders

2009-06-02 20:10

administrator   ~0028233

Can you get the back trace from the stack view? Maybe this occurs during the initialization and the widgetset object is not yet initialized. Putting the interfaces unit as first of the new project would fix that, maybe.

Kjow

2009-06-03 00:32

reporter   ~0028239

I'm sorry, I not speak english very well, so I ask you to have some patience with me :)
What do you mean with "back trace from the stack view"?
However, I noticed two things:

1) If I load an "old" project, that I started with Lazarus build <= 19499, it compiles and works very well! The problem is if I start a new project.

2) If I remove from "Form1" the GLScene component and from "uses" the GLScene component, I have the same error. It seems to have GLScene however.

Vincent Snijders

2009-06-03 10:26

administrator   ~0028244

* (optional) switch IDE language to english
* load test project
* press F9 to run it
* when you get an access violation, break the program execution
* Choose in the menu View -> Debug windows -> Call Stack
* Copy all lines to the clipboard and attach them to the bug report.

Vincent Snijders

2009-06-03 10:29

administrator   ~0028245

Can you paste the uses section of the wrong project1.lpr. I cannot open the file from the archive: 7zip gives unsupported compression method.

Anton Kavalenka

2009-06-03 10:50

reporter   ~0028246

archive is compressed with ZIP method 14 (LZMA),
use the latest 7zip

Vincent Snijders

2009-06-03 11:06

administrator   ~0028247

Thanks Anton, that works.

Kjow, edit the uses section of project1.lpr so that it looks like:
uses
  {$IFDEF UNIX}{$IFDEF UseCThreads}
  cthreads,
  {$ENDIF}{$ENDIF}
  Interfaces, // this includes the LCL widgetset
  Forms, Unit1, LResources
  { you can add units after this },
  glscenelazarus;

Kjow

2009-06-03 11:42

reporter   ~0028248

It works!
Now it compiles and it runs very well.
Thank you very much!

So, is this a "bug" that will be corrected? Or everytime that we will start a glscene project, must we make this modify?

Congratulations for work, you are great!


PS Do you need however what you wrote in post n° 0028244?

Vincent Snijders

2009-06-03 12:33

administrator   ~0028251

The stack trace is not necessary anymore.

I created a new report, to request that the order of units in a new project are less susceptible to these kind of errors.

Issue History

Date Modified Username Field Change
2009-05-22 13:55 Kjow New Issue
2009-05-22 13:55 Kjow Widgetset => Win32
2009-05-22 22:04 Vincent Snijders LazTarget => 0.9.28
2009-05-22 22:04 Vincent Snijders Note Added: 0027883
2009-05-22 22:04 Vincent Snijders Status new => acknowledged
2009-05-22 22:04 Vincent Snijders Target Version => 0.9.28
2009-05-25 19:15 Kjow Note Added: 0027974
2009-05-25 19:17 Kjow Note Edited: 0027974
2009-06-02 19:27 Kjow File Added: Laz19499.zip
2009-06-02 19:27 Kjow File Added: Laz20339.zip
2009-06-02 19:28 Kjow File Added: Immagine.png
2009-06-02 19:28 Kjow File Added: Immagine2.png
2009-06-02 19:47 Kjow Note Added: 0028232
2009-06-02 19:49 Kjow Note Edited: 0028232
2009-06-02 19:52 Vincent Snijders Reproducibility have not tried => always
2009-06-02 20:10 Vincent Snijders Note Added: 0028233
2009-06-03 00:32 Kjow Note Added: 0028239
2009-06-03 00:34 Kjow Tag Attached: EXTERNAL
2009-06-03 00:34 Kjow Tag Attached: GetSysColor
2009-06-03 00:34 Kjow Tag Attached: GLScene
2009-06-03 00:34 Kjow Tag Attached: SIGSEGV
2009-06-03 00:34 Kjow Tag Attached: Windows 7
2009-06-03 10:26 Vincent Snijders Note Added: 0028244
2009-06-03 10:29 Vincent Snijders Note Added: 0028245
2009-06-03 10:50 Anton Kavalenka Note Added: 0028246
2009-06-03 11:06 Vincent Snijders Note Added: 0028247
2009-06-03 11:42 Kjow Note Added: 0028248
2009-06-03 12:27 Vincent Snijders Relationship added related to 0013899
2009-06-03 12:33 Vincent Snijders Status acknowledged => resolved
2009-06-03 12:33 Vincent Snijders Resolution open => no change required
2009-06-03 12:33 Vincent Snijders Assigned To => Vincent Snijders
2009-06-03 12:33 Vincent Snijders Note Added: 0028251
2009-09-03 19:48 Vincent Snijders Project Packages => Lazarus CCR