View Issue Details

IDProjectCategoryView StatusLast Update
0013873Lazarus CCR-public2009-09-03 19:55
ReporterSteve ColeAssigned ToVincent Snijders 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Summary0013873: Adding SdpoSerial component to form stops program running
DescriptionSVN revision 20286
Linux GTK2
FPC Ver 2.2.4

The SdpoSerial component is added to the front of the project *.lpr file uses section, before cthreads.

uses
  {$IFDEF UNIX}{$IFDEF UseCThreads}
  SdpoSerialLaz, cthreads,
  {$ENDIF}{$ENDIF}
  Interfaces, // this includes the LCL widgetset
  Forms, Unit1
  { you can add units after this };
                                            

The program will not run unless cthreads is placed first.
TagsNo tags attached.
WidgetsetGTK 2
Attached Files

Activities

Steve Cole

2009-05-31 09:03

reporter   ~0028164

Does it need to be added to the project.lpr file?
Deleting the reference to SdpoSerialLaz allows the program to run.

Vincent Snijders

2009-05-31 19:58

administrator   ~0028180

Your suggestion for seems to be good. Although if I test with another component (ACS), the package unit is added as last to the lpr.

Please contact the authors to get your fixes into the their sources, the Lazarus team does not maintain this component.

This may be the correct bug tracker, but I see no previous issues:
https://sourceforge.net/tracker/?group_id=214994&atid=1031891

Issue History

Date Modified Username Field Change
2009-05-31 08:49 Steve Cole New Issue
2009-05-31 08:49 Steve Cole Widgetset => GTK 2
2009-05-31 09:03 Steve Cole Note Added: 0028164
2009-05-31 19:58 Vincent Snijders LazTarget => -
2009-05-31 19:58 Vincent Snijders Status new => resolved
2009-05-31 19:58 Vincent Snijders Resolution open => fixed
2009-05-31 19:58 Vincent Snijders Assigned To => Vincent Snijders
2009-05-31 19:58 Vincent Snijders Note Added: 0028180
2009-09-03 19:55 Vincent Snijders Project Packages => Lazarus CCR