View Issue Details

IDProjectCategoryView StatusLast Update
0013899LazarusIDEpublic2009-06-03 19:37
ReporterVincent Snijders Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSWindows 
Product Version0.9.27 (SVN) 
Target Version0.9.28Fixed in Version0.9.27 (SVN) 
Summary0013899: GLScene units added in the wrong place in the uses section
DescriptionMy Lazarus Directory is c:\lazarus\source\lazarus.

My FPC Source Directory is c:\lazarus\source\fpc\2.3

The GLScene package is in C:\lazarus\source\fpcprojects\glscene\trunk\Lazarus\glscenelazarus.lpk and the glscene unit is in C:\lazarus\source\fpcprojects\glscene\trunk\Source\glscene.pas.

In Options -> Codetools -> Code creation -> New units are added to uses section: behind related.

If I drop a TGlScene component on the form, the GLScene unit is added as first unit, even before the classes unit. I would prefer it to be put after the LCL units, because the GLScene package depends on the LCL package.

The uses section of the .lpr looks like:
uses
  {$IFDEF UNIX}{$IFDEF UseCThreads}
  cthreads,
  {$ENDIF}{$ENDIF}
  glscenelazarus, Interfaces, // this includes the LCL widgetset
  Forms, Unit1, LResources
  { you can add units after this };

The glscenelazarus unit (the main unit of the glscene package) is added before the interfaces unit. This causes errors if one the units used by GLScene uses the WidgetSet object indirectly. Since it glscene package depends on the LCL, it would be more logical to add the unit after the LCL units.

See related issue 0013790, for the effects of this place of the glscenelazarus unit. It seems that since the restructuring of the widget set functions, the order of the used units has become more important.
TagsNo tags attached.
Fixed in Revision20376
LazTarget0.9.28
Widgetset
Attached Files

Relationships

related to 0013790 resolvedVincent Snijders Lazarus CCR GLScene problem on latest builds & Windows 7 

Activities

Kjow

2009-06-03 18:19

reporter   ~0028261

Hi again! :)

Just for knowledge: I tried under Ubuntu now (today's snapshots, I had no possibilities before today) and there is the same problem.

So it isn't a problem of Windows only.

Mattias Gaertner

2009-06-03 18:32

manager   ~0028262

Related is measured in directory distance.
So glscene is same related to the FCL and to the LCL.
I changed the default of "behind related." to as last unit.
Please test and if ok mark this bug as closed.

Vincent Snijders

2009-06-03 19:37

manager   ~0028263

Thanks, this solves the issue. I had seen it uses the directory distance, but did not think about putting it last.

Issue History

Date Modified Username Field Change
2009-06-03 12:27 Vincent Snijders New Issue
2009-06-03 12:27 Vincent Snijders LazTarget => -
2009-06-03 12:27 Vincent Snijders Relationship added related to 0013790
2009-06-03 12:28 Vincent Snijders Status new => assigned
2009-06-03 12:28 Vincent Snijders Assigned To => Mattias Gaertner
2009-06-03 12:28 Vincent Snijders LazTarget - => 0.9.28
2009-06-03 12:28 Vincent Snijders Target Version => 0.9.28
2009-06-03 18:19 Kjow Note Added: 0028261
2009-06-03 18:32 Mattias Gaertner Fixed in Revision => 20376
2009-06-03 18:32 Mattias Gaertner Note Added: 0028262
2009-06-03 18:32 Mattias Gaertner Status assigned => resolved
2009-06-03 18:32 Mattias Gaertner Resolution open => fixed
2009-06-03 19:37 Vincent Snijders Status resolved => closed
2009-06-03 19:37 Vincent Snijders Note Added: 0028263
2009-06-03 19:37 Vincent Snijders Fixed in Version => 0.9.27 (SVN)