View Issue Details

IDProjectCategoryView StatusLast Update
0013932LazarusWidgetsetpublic2010-05-05 19:00
ReporterYuriy SydorovAssigned ToPaul Ishenin 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWin32/64OSWinXPOS Version
Product Version0.9.27 (SVN)Product Build 
Target Version1.0.0Fixed in Version0.9.29 (SVN) 
Summary0013932: Double click is needed to select/deselect item's checkbox in listview with checkboxes
DescriptionSingle mouse click does not select/deselect item's checkbox in listview with checkboxes.
See attached demo project.
TagsNo tags attached.
Fixed in Revision25158
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Activities

2009-06-08 11:29

 

lv.zip (130,845 bytes)

Paul Ishenin

2009-09-12 10:58

manager   ~0030651

Can't reproduce. Is it already fixed?

Vincent Snijders

2009-09-12 11:22

manager   ~0030652

Just a week ago, I could reproduce it with one of my test projects.

Andrzej Kilijanski

2009-10-08 22:39

reporter   ~0031211

I made some tests:
- Windows XP - everything works ok
- Windows Vista 32bit Home Premium - I need 2 or sometimes 4 clicks to change checkboxes state.

Martin Friebe

2009-11-05 21:18

manager   ~0031917

I can confirm (on Vista), with Lazarus trunc.
Single click does not affect the checkbox
Double Click works

Never needed more than a double-click, but it must be proper DoubleClick (in time). Two separate single-click will not change the checkbox

Andrzej Kilijanski

2009-11-05 21:37

reporter   ~0031918

You are right,
I tested with another mouse, only double clicks needed to change checkboxes state.
Hardware problem with 4 clicks

Checking with Spacebar works OK in Vista.

Vincent Snijders

2009-11-06 10:13

manager   ~0031931

I have this problem on windows XP.

Andrzej Kilijanski

2009-11-09 00:03

reporter   ~0032015

I tested it again and I can't reproduce this on Windows XP (with or without manifest).

On Vista always need two clicks.

Paul Ishenin

2010-05-04 03:57

manager   ~0037217

Please test and close if ok.

Mattias Gaertner

2010-05-05 19:00

manager   ~0037296

See mailing list Wed, 05 May 2010 18:54:55 +0200

Issue History

Date Modified Username Field Change
2009-06-08 11:27 Yuriy Sydorov New Issue
2009-06-08 11:27 Yuriy Sydorov LazTarget => -
2009-06-08 11:27 Yuriy Sydorov Widgetset => Win32
2009-06-08 11:29 Yuriy Sydorov File Added: lv.zip
2009-06-08 12:35 Vincent Snijders LazTarget - => 1.0
2009-06-08 12:35 Vincent Snijders Status new => acknowledged
2009-06-08 12:35 Vincent Snijders Target Version => 1.0.0
2009-09-12 10:58 Paul Ishenin Note Added: 0030651
2009-09-12 10:58 Paul Ishenin Status acknowledged => feedback
2009-09-12 11:22 Vincent Snijders Note Added: 0030652
2009-10-08 22:39 Andrzej Kilijanski Note Added: 0031211
2009-11-05 21:18 Martin Friebe Note Added: 0031917
2009-11-05 21:37 Andrzej Kilijanski Note Added: 0031918
2009-11-06 10:13 Vincent Snijders Note Added: 0031931
2009-11-06 10:13 Vincent Snijders Status feedback => acknowledged
2009-11-09 00:03 Andrzej Kilijanski Note Added: 0032015
2010-05-04 03:57 Paul Ishenin Fixed in Revision => 25158
2010-05-04 03:57 Paul Ishenin Status acknowledged => resolved
2010-05-04 03:57 Paul Ishenin Fixed in Version => 0.9.29 (SVN)
2010-05-04 03:57 Paul Ishenin Resolution open => fixed
2010-05-04 03:57 Paul Ishenin Assigned To => Paul Ishenin
2010-05-04 03:57 Paul Ishenin Note Added: 0037217
2010-05-05 19:00 Mattias Gaertner Status resolved => closed
2010-05-05 19:00 Mattias Gaertner Note Added: 0037296