View Issue Details

IDProjectCategoryView StatusLast Update
0013939LazarusLCLpublic2009-09-03 10:19
ReporterTsvetoslav Assigned ToPaul Ishenin  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformi386OSwindows 
Product Version0.9.27 (SVN) 
Target Version1.0.0Fixed in Version0.9.27 (SVN) 
Summary0013939: TRadioButton and tab key/tab order broken again
DescriptionUsing tab key with group of TRadionButton controls does not work well - in some cases it selects unchecked TRadionButton and makes it checked.
Steps To ReproduceCompile and run the attached program. Press the tab key several times to move the focus - everything is OK, only the first radio button is selected.
Now, select the second radio button (RadioButton2) with the mouse - it becomes focused and checked. Press the tab key - the focus is moved to Edit2 control, while one would expect Edit3 to be focused. Press again tab control a few times - RadioButton1 becomes focused and checked.
If you select/check the RadioButton3 with the mouse and then use the tab key to move around you'll see that any of the radio buttons will be selected/checked and the tab order is broken - RB1 - Edit1 - RB2 - Edit2 - Edit3 - RB3 - Edit4 - ...
TagsNo tags attached.
Fixed in Revision20564
LazTarget1.0
WidgetsetWin32/Win64
Attached Files

Activities

2009-06-09 11:09

 

rbtest.zip (347,443 bytes)

Paul Ishenin

2009-06-10 05:05

manager   ~0028414

Please test and close if ok.

Tsvetoslav

2009-09-03 10:19

reporter   ~0030359

I can't reproduce it anymore, so it must be fixed. Thanks!

Issue History

Date Modified Username Field Change
2009-06-09 11:09 Tsvetoslav New Issue
2009-06-09 11:09 Tsvetoslav File Added: rbtest.zip
2009-06-09 11:09 Tsvetoslav Widgetset => Win32
2009-06-09 14:01 Vincent Snijders LazTarget => 1.0
2009-06-09 14:01 Vincent Snijders Status new => acknowledged
2009-06-09 14:01 Vincent Snijders Target Version => 1.0.0
2009-06-10 05:05 Paul Ishenin Fixed in Revision => 20564
2009-06-10 05:05 Paul Ishenin Status acknowledged => resolved
2009-06-10 05:05 Paul Ishenin Fixed in Version => 0.9.27 (SVN)
2009-06-10 05:05 Paul Ishenin Resolution open => fixed
2009-06-10 05:05 Paul Ishenin Assigned To => Paul Ishenin
2009-06-10 05:05 Paul Ishenin Note Added: 0028414
2009-09-03 10:19 Tsvetoslav Status resolved => closed
2009-09-03 10:19 Tsvetoslav Note Added: 0030359