View Issue Details

IDProjectCategoryView StatusLast Update
0013951LazarusLCLpublic2011-12-01 11:23
ReporterChristianAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN)Product Build 
Target Version0.9.30Fixed in Version0.9.29 (SVN) 
Summary0013951: TDBGrid eats first Char
Descriptionwhen ;)

1. An dataset is in dsBrowse
and 2. The dataset is an detaildataset
and 3. you type the first time an string into it (the DBGrid must do the insert)

then the dbgrid eats the first char of you input.
Steps To ReproduceOpen the attatched example
Maybe you have to set the path to the database in ZConnection and must set connected to true and active of the querrys to true.
Then start the application
Go to the lower DBGrid (detail)
Set the cursor in DESCR
type at example "test"
est should appear.
TagsNo tags attached.
Fixed in Revision23945
LazTarget0.9.30
WidgetsetGTK, GTK 2, Win32/Win64
Attached Files

Activities

2009-06-10 15:23

 

test.zip (169,103 bytes)

Vincent Snijders

2009-06-10 15:31

manager   ~0028448

Does this problem occur in 0.9.27 too?

Christian

2009-06-10 22:55

reporter   ~0028460

oh i dont se the correct version, yes occours in current svn. i have this problem since years but cant easyly reproduce it.

Christian

2010-02-07 19:47

reporter   ~0034279

seems that this is only happen when inplace editors are active. when the grid has the focus and you type the first char then the char is correct entered in the inplace editor. when the inplaye editor is already active then the first char is lost.

Jesus Reyes

2010-02-09 21:52

developer   ~0034337

I'm sorry but it seems that in order to trigger the bug something special needs to be done, because I can't reproduce when I tried everything I ask below.

Please state what field should be selected in both the upper grid and the lower grid?, how do you select the fields by keyboard by mouse or doesn't matter?, how to show the in place editor, by keyboard, by clicking/double-clicking or doesn't matter? for the selected field, what needs to be typed (note that according to the field type some characters may not be allowed).

Christian

2010-02-10 07:07

reporter   ~0034343

No definitivly not.
1. Select the deail Dataset.
2. Klick in an row to get the inplace editor
3. type an char -> you see it
the inplace editor is hidden and the clean row is showed and the dataset is now in edit state. Every next char you type is correct handled by the grid.
But ist very anoying when you have to klick or type 2 times per item.

btw. sorry for the absoulue path in the connection

Jesus Reyes

2010-03-11 17:08

developer   ~0035271

I finally was able to reproduce the problem while was investigating some other issue. This issue is reported to occur under GTK and that is what I was testing unsuccessfully.

The missing key here it seems, was an empty editable grid under windows.

Please test.

Issue History

Date Modified Username Field Change
2009-06-10 15:22 Christian New Issue
2009-06-10 15:22 Christian Widgetset => GTK, GTK 2, Win32
2009-06-10 15:23 Christian File Added: test.zip
2009-06-10 15:30 Vincent Snijders LazTarget => 1.0
2009-06-10 15:30 Vincent Snijders Assigned To => Jesus Reyes
2009-06-10 15:30 Vincent Snijders Status new => assigned
2009-06-10 15:30 Vincent Snijders Target Version => 1.0.0
2009-06-10 15:31 Vincent Snijders Note Added: 0028448
2009-06-10 22:55 Christian Note Added: 0028460
2009-06-10 23:21 Vincent Snijders Product Version 0.9.26.3 (SVN) => 0.9.27 (SVN)
2010-02-07 19:47 Christian Note Added: 0034279
2010-02-09 21:52 Jesus Reyes Note Added: 0034337
2010-02-09 21:52 Jesus Reyes Status assigned => feedback
2010-02-10 07:07 Christian Note Added: 0034343
2010-03-11 17:08 Jesus Reyes Fixed in Revision => 23945
2010-03-11 17:08 Jesus Reyes LazTarget 1.0 => 0.9.30
2010-03-11 17:08 Jesus Reyes Status feedback => resolved
2010-03-11 17:08 Jesus Reyes Fixed in Version => 0.9.29 (SVN)
2010-03-11 17:08 Jesus Reyes Resolution open => fixed
2010-03-11 17:08 Jesus Reyes Note Added: 0035271
2010-03-11 17:08 Jesus Reyes Target Version 1.0.0 => 0.9.30
2011-12-01 11:23 Marc Weustink Status resolved => closed