View Issue Details

IDProjectCategoryView StatusLast Update
0013961LazarusLCLpublic2012-01-04 21:54
ReporterVladimir ZhirovAssigned ToBart Broersma 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN)Product Build 
Target Version1.2.0Fixed in Version0.9.31 (SVN) 
Summary0013961: Missing published TSpeedButton.Autosize property
DescriptionIn contrast to other button components SpeedButton has its Autosize property public, not published.
TagsNo tags attached.
Fixed in Revisionr34398
LazTarget1.2
Widgetset
Attached Files

Relationships

has duplicate 0020674 closedZeljan Rikalo AutoSize does not work in SpeedButton 

Activities

Paul Ishenin

2009-06-13 11:08

manager   ~0028516

It is so because nobody implemented AutoSize calculations for it.

samuel herzog

2009-07-18 14:17

developer   ~0029160

Why is TSpeedButton inherited from TGraphicControl and not from TCustomButton ?
Does someone know the reason ?
TCustomButton already handles "AutoSize" while the TGraphicControl does not.

To solve this issue we have three possibilities:

A) won't do, because TSpeedButton shall not be used for AutoSize.
B) change inheritance of TSpeedButton.
C) copy autosize-code to TSpeedButton.

I vote for A or B.

Paul Ishenin

2009-07-18 14:49

manager   ~0029161

Why do you ask here? Use mail list for discussions. But
1. TSpeedButton is called speed because it does not have window handle. Therefore it can't be TCustomControl. TGraphicControl is the one right ancestor.
2. Some one need to write autosize code like we did for TLabel before.

As result it is not A, B, or C. It is D) implement autosize for TSpeedButton.

Zeljan Rikalo

2011-12-28 08:28

developer   ~0055321

Mattias implemented AutoSize in r34398. Can you test ?

Vladimir Zhirov

2012-01-04 09:15

reporter   ~0055464

Last edited: 2012-01-04 09:18

Tested with r34494. The property is here and I cannot reproduce 0020674 with lcl-qt, so I'm ready to close this issue. Thanks.

Bart Broersma

2012-01-04 13:19

developer   ~0055469

As stated by original reproter, the issue is fixed.
Please close.

Issue History

Date Modified Username Field Change
2009-06-11 18:13 Vladimir Zhirov New Issue
2009-06-11 23:54 Vincent Snijders LazTarget => 1.0
2009-06-11 23:54 Vincent Snijders Status new => acknowledged
2009-06-11 23:54 Vincent Snijders Target Version => 1.0.0
2009-06-13 11:08 Paul Ishenin Note Added: 0028516
2009-07-18 14:17 samuel herzog Note Added: 0029160
2009-07-18 14:49 Paul Ishenin Note Added: 0029161
2011-10-07 20:22 Vincent Snijders LazTarget 1.0 => 1.2
2011-10-07 20:22 Vincent Snijders Severity minor => feature
2011-10-07 20:22 Vincent Snijders Target Version 1.0.0 => 1.2.0
2011-11-13 18:04 Zeljan Rikalo Relationship added has duplicate 0020674
2011-12-28 08:28 Zeljan Rikalo Note Added: 0055321
2011-12-28 08:28 Zeljan Rikalo Status acknowledged => feedback
2012-01-04 09:15 Vladimir Zhirov Note Added: 0055464
2012-01-04 09:16 Vladimir Zhirov Note Edited: 0055464
2012-01-04 09:18 Vladimir Zhirov Note Edited: 0055464
2012-01-04 13:19 Bart Broersma Fixed in Revision => r34398
2012-01-04 13:19 Bart Broersma Status feedback => resolved
2012-01-04 13:19 Bart Broersma Fixed in Version => 0.9.31 (SVN)
2012-01-04 13:19 Bart Broersma Resolution open => fixed
2012-01-04 13:19 Bart Broersma Assigned To => Bart Broersma
2012-01-04 13:19 Bart Broersma Note Added: 0055469
2012-01-04 21:54 Vladimir Zhirov Status resolved => closed