View Issue Details

IDProjectCategoryView StatusLast Update
0013964LazarusOtherpublic2009-10-23 00:40
ReporterEugen Bolz Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version0.9.28Fixed in Version0.9.27 (SVN) 
Summary0013964: SynEdit.ScrollBars := ssAutoBoth; dont show Scrollbars
DescriptionSynEdit.ScrollBars := ssAutoBoth;

Enough Text in the SynEdit and still no Scrollbars.
TagsNo tags attached.
Fixed in Revision20594
LazTarget0.9.28
Widgetset
Attached Files

Activities

Eugen Bolz

2009-06-11 20:10

reporter   ~0028484

Under GTK2 the same Problem

Martin Friebe

2009-06-12 16:00

manager   ~0028497

A few notes:

The horizontal scrollbar will not disappear, if you use ScrollPastEOL in the options (past end of LINE, not past end of file).
This is because in this case, horizontal scroll is always wanted.

Once scrollbars are shown, In order to have them disappearing you have to make the text small enough, to fit into the area that is visible (that is the text must be fully visible, even with the bars).
- SynEdit always checks with the current usable client-rect.
- SynEdit does not check with the theoretical available space, assuming the scrollbars weren't there.

Most other apps I tested do the same (or far worse).

Issue History

Date Modified Username Field Change
2009-06-11 19:27 Eugen Bolz New Issue
2009-06-11 19:27 Eugen Bolz Widgetset => Win32
2009-06-11 19:28 Martin Friebe Status new => assigned
2009-06-11 19:28 Martin Friebe Assigned To => Martin Friebe
2009-06-11 20:10 Eugen Bolz Note Added: 0028484
2009-06-12 16:00 Martin Friebe Fixed in Revision => 20594
2009-06-12 16:00 Martin Friebe LazTarget => 0.9.28
2009-06-12 16:00 Martin Friebe Widgetset Win32 =>
2009-06-12 16:00 Martin Friebe Status assigned => resolved
2009-06-12 16:00 Martin Friebe Fixed in Version => 0.9.27 (SVN)
2009-06-12 16:00 Martin Friebe Resolution open => fixed
2009-06-12 16:00 Martin Friebe Note Added: 0028497
2009-06-12 16:00 Martin Friebe Target Version => 0.9.28
2009-10-23 00:40 Marc Weustink Status resolved => closed