View Issue Details

IDProjectCategoryView StatusLast Update
0013965FPCFCLpublic2010-03-06 21:25
ReporterAttila Borka Assigned ToMarco van de Voort  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindows XP SP3 
Product Version2.3.1 
Fixed in Version2.4.0 
Summary0013965: fastcgi (fcgi) programs do not compile under windows
DescriptionReceiving the following error message when trying to compile any fcgi program under Windows:

"fastcgi.pp(1,1) Fatal: Can't find unit BaseUnix used by custfcgi"

There is no BaseUnix unit under Windows.
TagsNo tags attached.
Fixed in Revision13270
FPCOldBugId
FPCTarget
Attached Files

Activities

Marco van de Voort

2009-06-14 00:21

manager   ~0028526

Fastcgi and friends are not flagged for compilation under non-linux. Not even for BSD.

Marco van de Voort

2009-06-14 00:45

manager   ~0028527

Now at least compiles, and since it now does on *nix and Windows enabled it for all in the makefile. Hope that OS X has MSG_SIGNAL.

Jonas Maebe

2009-06-14 01:30

manager   ~0028528

> Hope that OS X has MSG_SIGNAL.

It doesn't.

Issue History

Date Modified Username Field Change
2009-06-11 20:21 Attila Borka New Issue
2009-06-14 00:21 Marco van de Voort Note Added: 0028526
2009-06-14 00:45 Marco van de Voort Fixed in Revision => 13270
2009-06-14 00:45 Marco van de Voort Status new => resolved
2009-06-14 00:45 Marco van de Voort Fixed in Version => 2.3.1
2009-06-14 00:45 Marco van de Voort Resolution open => fixed
2009-06-14 00:45 Marco van de Voort Assigned To => Marco van de Voort
2009-06-14 00:45 Marco van de Voort Note Added: 0028527
2009-06-14 01:30 Jonas Maebe Note Added: 0028528
2010-03-06 21:25 Jonas Maebe Status resolved => closed