View Issue Details

IDProjectCategoryView StatusLast Update
0013977LazarusIDEpublic2009-10-23 00:40
ReporterIgor Tolstov  Assigned ToVincent Snijders  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version0.9.28Fixed in Version0.9.27 (SVN) 
Summary0013977: Lazbuild not resend key to fpc
Descriptioni try compule from linux i386 to windows64

lazbuild -B --widgetset=win64 --os=win64 --cpu=x86_64 components/CmdLine/cmdbox.lpk --compiler=/usr/local/bin/ppcrossx64

but get

TLazPackageGraph.CheckIfPackageNeedsCompilation No state file for cmdbox 0.0
[TExternalToolList.Run] CmdLine="/usr/local/bin/ppcrossx64 -B -MObjFPC -Scgi -O1 -gl -vewnhi -l "-Fu/components/CmdLine" -Fu/lcl/units/x86_64-win64/ -Fu/lcl/units/x86_64-win64/win64/ -Fu/packager/units/x86_64-win64/ -Fu/components/CmdLine/ -Fu. -FU/components/CmdLine/lib/x86_64-win64/ -dLCL -dLCLwin64 cmdbox.pas" WorkDir="/components/CmdLine/"
Hint: Start of reading config file /etc/fpc.cfg
Hint: End of reading config file /etc/fpc.cfg
Free Pascal Compiler version 2.2.4 [2009/06/14] for x86_64
Copyright (c) 1993-2008 by Florian Klaempfl
Target OS: Linux for x86-64

ther are no key -Twin64 and -Px86_64
TagsNo tags attached.
Fixed in Revision20657
LazTarget0.9.28
Widgetset
Attached Files

Activities

Vincent Snijders

2009-06-17 21:49

manager   ~0028590

I cannot reproduce this:

vincent@fpclin32:~/src/laztrunk$ ./lazbuild -B --cpu=x86_64 --os=win64 --compiler=/home/vincent/fpc/bin/fpc components/tachart/demo/3d/zdemo.lpi
TLazPackageGraph.CheckIfPackageNeedsCompilation No state file for TAChartLazarusPkg 1.0
[TExternalToolList.Run] CmdLine="/home/vincent/fpc/bin/fpc -B -MObjFPC -Scgi -O1 -Twin64 -Px86_64 -gl -vewnhi -l -Fu/home/vincent/src/laztrunk/ideintf/units/x86_64-win64/ -Fu/home/vincent/src/laztrunk/lcl/units/x86_64-win64/ -Fu/home/vincent/src/laztrunk/lcl/units/x86_64-win64/gtk2/ -Fu/home/vincent/src/laztrunk/packager/units/x86_64-win64/ -Fu/home/vincent/src/laztrunk/components/tachart/ -Fu. -FU/home/vincent/src/laztrunk/components/tachart/lib/x86_64-win64/gtk2/ -dLCL -dLCLgtk2 tachartlazaruspkg.pas" WorkDir="/home/vincent/src/laztrunk/components/tachart/"
Hint: Start of reading config file /home/vincent/.fpc.cfg
Hint: End of reading config file /home/vincent/.fpc.cfg
Free Pascal Compiler version 2.3.1 [2009/06/17] for x86_64
Copyright (c) 1993-2009 by Florian Klaempfl
Target OS: Win64 for x64

I have "-Twin64 -Px86_64" as parameters.

Vincent Snijders

2009-06-17 22:38

manager   ~0028591

It works correctly for projects, but not for packages.

Issue History

Date Modified Username Field Change
2009-06-14 18:14 Igor Tolstov New Issue
2009-06-17 21:49 Vincent Snijders Note Added: 0028590
2009-06-17 22:38 Vincent Snijders LazTarget => 0.9.26
2009-06-17 22:38 Vincent Snijders Note Added: 0028591
2009-06-17 22:38 Vincent Snijders Assigned To => Vincent Snijders
2009-06-17 22:38 Vincent Snijders Status new => confirmed
2009-06-17 22:38 Vincent Snijders Target Version => 0.9.28
2009-06-17 23:00 Vincent Snijders Fixed in Revision => 20657
2009-06-17 23:00 Vincent Snijders LazTarget 0.9.26 => 0.9.28
2009-06-17 23:00 Vincent Snijders Status confirmed => resolved
2009-06-17 23:00 Vincent Snijders Fixed in Version => 0.9.27 (SVN)
2009-06-17 23:00 Vincent Snijders Resolution open => fixed
2009-10-23 00:40 Marc Weustink Status resolved => closed