View Issue Details

IDProjectCategoryView StatusLast Update
0014058LazarusLCLpublic2011-10-28 11:17
ReporterGraeme GeldenhuysAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86OSUbuntu LinuxOS Version8.04.2
Product Version0.9.27 (SVN)Product Buildlatest revision 
Target VersionFixed in Version 
Summary0014058: TDateEdit: dropdown calendar doesn't close when I click outside it
DescriptionWhen the drowdown calendar is displayed and I try and click outside the downdown window, like on Button1 as shown in the screenshot, the calendar does not close. Even clicking on the Form1 the calendar does not close. Drowdown windows are supposed to close when focus is lost or moved to another component.

I have only tested this on GTK2 widgetset, so I do not know if other widgetsets are affected.
TagsNo tags attached.
Fixed in Revisionr33131
LazTarget1.2
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0020171 resolvedJuha Manninen TDateEdit dropdown doesn't close unless a date is selected 
related to 0014059 resolvedJuha Manninen TDateEdit: Main form's focus is lost when dropdown calendar is shown 
related to 0010190 closedPaul Ishenin TCalendar crash when activating dsShowWeekNumbers through OI 
related to 0020647 closedBart Broersma DateEdit and DateTimePicker drop-down calender does not close-up when moving the parent form. 

Activities

2009-06-26 10:19

 

screenshot.png (6,121 bytes)
screenshot.png (6,121 bytes)

Vincent Snijders

2009-06-29 11:39

manager   ~0028841

Same cause as 0014059: for gtk2 the dropdown is shown as a modal dialog.

Juha Manninen

2011-10-28 11:17

developer   ~0053543

Fixed together with 0020171.

Issue History

Date Modified Username Field Change
2009-06-26 10:19 Graeme Geldenhuys New Issue
2009-06-26 10:19 Graeme Geldenhuys File Added: screenshot.png
2009-06-26 10:19 Graeme Geldenhuys Widgetset => GTK 2
2009-06-29 11:38 Vincent Snijders Relationship added related to 0014059
2009-06-29 11:39 Vincent Snijders LazTarget => 1.2
2009-06-29 11:39 Vincent Snijders Note Added: 0028841
2009-06-29 11:39 Vincent Snijders Status new => acknowledged
2010-12-20 13:33 Juha Manninen Relationship added related to 0010190
2011-10-28 09:45 Juha Manninen Relationship added duplicate of 0020171
2011-10-28 09:45 Juha Manninen Status acknowledged => assigned
2011-10-28 09:45 Juha Manninen Assigned To => Juha Manninen
2011-10-28 11:17 Juha Manninen Fixed in Revision => r33131
2011-10-28 11:17 Juha Manninen Status assigned => resolved
2011-10-28 11:17 Juha Manninen Resolution open => fixed
2011-10-28 11:17 Juha Manninen Note Added: 0053543
2011-11-10 06:54 Juha Manninen Relationship added related to 0020647