View Issue Details

IDProjectCategoryView StatusLast Update
0014071LazarusLCLpublic2014-06-14 15:19
ReporterDenis Golovan Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.9.27 (SVN) 
Target Version1.2.0 
Summary0014071: TCheckListBox do not use OnDrawItem
DescriptionSeems like no code calls OnDrawItem.
Tested on gtk2 interface
TagsNo tags attached.
Fixed in Revision43178
LazTarget1.2
WidgetsetGTK 2
Attached Files

Relationships

related to 0007059 resolvedZeljan Rikalo TListView: OnCustomDraw event 
related to 0025149 closedZeljan Rikalo TListView missing OwnerDraw property 

Activities

Zeljan Rikalo

2012-02-04 13:13

developer   ~0056375

Not blocker, postponed.

Zeljan Rikalo

2012-03-17 12:45

developer   ~0057761

Not gtk2 only issue, under qt we have same thing. I think that we must add OwnerDraw property into such controls, so WS knows that it must pass item paint event to lcl.

Zeljan Rikalo

2013-10-07 16:58

developer   ~0070620

Qt works, Gtk2 doesn't work because custom renderers aren't setted up for this control.

Zeljan Rikalo

2013-10-08 20:33

developer   ~0070672

Please test and close if ok.

Denis Golovan

2014-06-14 15:19

reporter   ~0075685

Fixed. Thanks

Issue History

Date Modified Username Field Change
2009-06-28 13:23 Denis Golovan New Issue
2009-06-28 13:23 Denis Golovan Widgetset => GTK 2
2009-06-28 19:00 Vincent Snijders LazTarget => 1.0
2009-06-28 19:00 Vincent Snijders Status new => acknowledged
2009-06-28 19:00 Vincent Snijders Target Version => 1.0.0
2012-02-04 13:13 Zeljan Rikalo LazTarget 1.0 => 1.2
2012-02-04 13:13 Zeljan Rikalo Note Added: 0056375
2012-03-13 07:50 Vincent Snijders Target Version 1.0.0 => 1.2.0
2012-03-17 12:45 Zeljan Rikalo Note Added: 0057761
2012-03-17 12:46 Zeljan Rikalo Relationship added related to 0007059
2013-10-06 19:19 Zeljan Rikalo Assigned To => Zeljan Rikalo
2013-10-06 19:19 Zeljan Rikalo Status acknowledged => assigned
2013-10-06 20:03 Zeljan Rikalo Relationship added related to 0025149
2013-10-07 16:58 Zeljan Rikalo Note Added: 0070620
2013-10-08 20:33 Zeljan Rikalo Fixed in Revision => 43178
2013-10-08 20:33 Zeljan Rikalo Note Added: 0070672
2013-10-08 20:33 Zeljan Rikalo Status assigned => resolved
2013-10-08 20:33 Zeljan Rikalo Resolution open => fixed
2014-06-14 15:19 Denis Golovan Note Added: 0075685
2014-06-14 15:19 Denis Golovan Status resolved => closed