View Issue Details

IDProjectCategoryView StatusLast Update
0014085Lazarus CCR-public2009-09-03 19:52
ReporterindianajonesAssigned ToJosé Mejuto 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0014085: Spreadsheet Unit Read Problem
DescriptionI attached the following xls example. The format of this xls file is 97-2004.
The revision svn number of fpspreadsheet is 887.

The following code returns empty value.
Thanks

procedure TForm1.Button1Click(Sender: TObject);
var
   MyWorkbook : TsWorkbook;
   MyWorksheet:TsWorksheet;
begin
  MyWorkbook := TsWorkbook.Create;
  try
      MyWorkbook.ReadFromFile('/Users/macintoshmacbook/97-2004.xls', sfExcel8);
      MyWorksheet := MyWorkbook.GetFirstWorksheet;
      showmessage(MyWorksheet.ReadAsUTF8Text(2,0));
  finally
      MyWorkbook.free;
  end;
end;
Additional InformationMac OS X 10.5.7
FPC 2.2.4
Lazarus SVN 20763
TagsNo tags attached.
WidgetsetCarbon
Attached Files

Activities

2009-07-01 14:31

 

97-2004.xls (17,408 bytes)

Vincent Snijders

2009-07-01 15:15

administrator   ~0028889

Do you use a powerpc or intel CPU?

indianajones

2009-07-01 19:59

reporter   ~0028894

Intel CPU.

Felipe Monteiro de Carvalho

2009-08-08 04:33

developer   ~0029640

I confirmed it's not working, but the Excel 5 example works, in the mean time you can try using Excel 5 format or OpenDocument

José Mejuto

2009-09-02 01:03

developer   ~0030305

It does not work in BIFF8 format because it does not use regular labels, instead it uses SST labels which are intented to compress repeated strings in a excel file. It should work in current SVN, fixed 2 ago 2009.

It would be interesting to know why your example xls file contains encoded asian phonetics in both example strings :-?

José Mejuto

2009-09-02 17:13

developer   ~0030331

Please, close if OK.

Issue History

Date Modified Username Field Change
2009-07-01 14:31 indianajones New Issue
2009-07-01 14:31 indianajones File Added: 97-2004.xls
2009-07-01 14:31 indianajones Widgetset => Carbon
2009-07-01 15:14 Vincent Snijders Project Lazarus => Packages
2009-07-01 15:14 Vincent Snijders LazTarget => -
2009-07-01 15:14 Vincent Snijders Category LCL => -
2009-07-01 15:14 Vincent Snijders Description Updated
2009-07-01 15:14 Vincent Snijders Additional Information Updated
2009-07-01 15:15 Vincent Snijders Note Added: 0028889
2009-07-01 15:15 Vincent Snijders Assigned To => Felipe Monteiro de Carvalho
2009-07-01 15:15 Vincent Snijders Status new => feedback
2009-07-01 19:59 indianajones Note Added: 0028894
2009-07-01 21:28 Vincent Snijders Status feedback => assigned
2009-08-08 04:33 Felipe Monteiro de Carvalho Note Added: 0029640
2009-09-02 01:03 José Mejuto Note Added: 0030305
2009-09-02 17:11 José Mejuto Assigned To Felipe Monteiro de Carvalho => José Mejuto
2009-09-02 17:13 José Mejuto Fixed in Revision => 945
2009-09-02 17:13 José Mejuto Status assigned => resolved
2009-09-02 17:13 José Mejuto Resolution open => fixed
2009-09-02 17:13 José Mejuto Note Added: 0030331
2009-09-03 19:52 Vincent Snijders Project Packages => Lazarus CCR