View Issue Details

IDProjectCategoryView StatusLast Update
0014122LazarusIDEpublic2013-09-03 12:07
ReporterElphiAssigned ToMaxim Ganetsky 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.9.26.2Product Build 
Target VersionFixed in Version0.9.31 (SVN) 
Summary0014122: Default unitname in camelcase should be in lowercase.
DescriptionWhen saving a new project the default unitname Unit1 is presented in camel case. When consistent, it should be in lower case. Also, presenting a recommendation to rename the file to lowercase is less frequently needed.
TagsNo tags attached.
Fixed in Revision31909
LazTarget1.4
Widgetset
Attached Files

Activities

Vincent Snijders

2009-07-10 12:30

manager   ~0029013

Can't you change the naming options to achieve this?

Elphi

2009-07-10 14:17

reporter   ~0029014

Of course I can. But it is advisable to consistently promote the use of lower case. Note that when saving a new project the default project name project1 is in lower case. It's not a big deal, but tweaking this code isn't a big deal either, isn't it?

Vincent Snijders

2009-07-10 14:52

manager   ~0029015

If it isn't a big deal, please provide a patch.

What is the tweak? IMHO, the unit name should be PascalCase as that is the good practice for pascal identifiers. Do you suggest to let the option 'Save as - autorename pascal files to lower case' have 'autorename file lower case' as default?

samuel herzog

2009-07-11 08:57

developer   ~0029040

I am also annoyed because this question is asked each time I save a new project.
Maybe there should be a checkbox on the question dialog to say "Don't ask me again".

Elphi

2009-07-11 09:34

reporter   ~0029041

I don't think there's any need for that. The naming option 'no automatic renaming' (should be: 'No automatic renaming' btw) does just that. Along with a default presentation in lower case, this should be the default naming option.

Vincent Snijders

2009-08-03 13:01

manager   ~0029474

No patch yet, so I set the target to post 1.0.

Also, IMHO, the unit name should be PascalCase, the file name may depend on the naming options.

Maxim Ganetsky

2011-08-07 17:25

developer   ~0050593

Please test and close if ok.

Joe Merten

2013-05-31 12:46

reporter   ~0067959

For my opinion, I prefer to use filenames also in CamelCase.
But ok, I respect that other users has other preferences.
In earlier versions, the default naming setting was »ask«.
But now (in 1.0.8) it is »Always«.

Currently, I find the following a little irritating:
* I create a new project with e.g. 1 form
* I save the project
* The IDE asks ("Save project" file dialog) for the project filename
  * I enter "MyProject.lpi"
* Then the IDE asks ("Save unit" file dialog) for the unit filename
  * I enter "MyUnit.pas"
* And now in my filesytem I found
  * All projectfiles like "MyProject.lpi" etc.
    (yep, that's what I'd expected after I typed that in a file dialog)
  * The files "myunit.pas" and "myunit.lfm"
    (oh whats that? That's not what I typed in into the file dialog)
    * My filesystem supports uppercase and lowercase characters and I explicit want to use this.
      That's the reason why I typed uppercase and lowercase characters into the file dialog.

Especially new users (some of them asked me about this curious behavior) have to explore the mass of configuration settings
(that's not criticism - I like to customize Lazarus for my personal preferences) to find the right setting.

Conclusion:
I vote for the earlier dafault setting "Ask" and adding a checkbox "Don't ask me again" (like samuel suggestet in 0014122:0029040).
And maybe add a hint to the Ask-dialog, were this setting is located in the IDE Options tree.

Issue History

Date Modified Username Field Change
2009-07-10 12:05 Elphi New Issue
2009-07-10 12:30 Vincent Snijders Note Added: 0029013
2009-07-10 14:17 Elphi Note Added: 0029014
2009-07-10 14:52 Vincent Snijders Note Added: 0029015
2009-07-11 08:57 samuel herzog Note Added: 0029040
2009-07-11 09:34 Elphi Note Added: 0029041
2009-08-03 13:01 Vincent Snijders LazTarget => post 1.2
2009-08-03 13:01 Vincent Snijders Note Added: 0029474
2009-08-03 13:01 Vincent Snijders Status new => acknowledged
2009-08-03 13:01 Vincent Snijders Severity tweak => feature
2011-08-07 17:25 Maxim Ganetsky Fixed in Revision => 31909
2011-08-07 17:25 Maxim Ganetsky Status acknowledged => resolved
2011-08-07 17:25 Maxim Ganetsky Fixed in Version => 0.9.31 (SVN)
2011-08-07 17:25 Maxim Ganetsky Resolution open => fixed
2011-08-07 17:25 Maxim Ganetsky Assigned To => Maxim Ganetsky
2011-08-07 17:25 Maxim Ganetsky Note Added: 0050593
2013-05-31 12:46 Joe Merten Note Added: 0067959
2013-09-03 12:07 Martin Friebe LazTarget post 1.2 => 1.4